Questions:

[Q1] Tell me the name of a protein you are interested in. Include the species and the accession
number. This can be a human protein or a protein from any other species as long as it's function
is known.

I you do not have a favorite protein, select human RBP4 or KIF11. Do not use beta globin as
this is in the worked example report that | provide you with online.

[Q2] Perform a BLAST search against a DNA database, such as a database consisting of
genomic DNA or ESTs. The BLAST server can be at NCBI or elsewhere. Include details of the
BLAST method used, database searched and any limits applied (e.g. Organism)

Also include the output of that BLAST search in your document. If appropriate, change the font
to Courier size 10 so that the results are displayed neatly. You can also screen capture a
BLAST output (e.g. alt print screen on a PC or on a MAC press 3-shift-4. The pointer becomes
abulls eye. Select the area you wish to capture and release. The image is saved as a file called
Screen Shot [].png in your Desktop directory). Itis not necessary to print out all of the
blast results if there are many pages.

On the BLAST results, clearly indicate a match that represents a protein sequence,
encoded from some DNA sequence, that is homologous to your query protein. | need to
be able to inspect the pairwise alignment you have selected, including the E value and
score. It should be labeled a "genomic clone" or "mRNA sequence”, etc. - but include no
functional annotation.

In general, [Q2] is the most difficult for students because it requires you to have a “feel”
for how to interpret BLAST results. You need to distinguish between a perfect match to

your query (i.e. a sequence that is not “novel), a near match (something that might be

“novel’, depending on the results of [Q4]), and a non-homologous result.

If you are having trouble finding a novel gene try restricting your search to an organism
that is poorly annotated.

Q3] Gather information about this “novel” protein. At a minimum, show me the protein
sequence of the “novel” protein as displayed in your BLAST results from [Q2] as FASTA
format (you can copy and paste the aligned sequence subject lines from your BLAST
result page if necessary) o translate your novel DNA sequence using a tool called
EMBOSS Transeq at the EBI. Don't forget to translate all six reading frames; the ORF
(open reading frame) is likely to be the longest sequence without a stop codon. It may
not start with a methionine if you don't have the complete coding region. Make sure the
sequence you provide includes a header/subject line and is in traditional FASTA format.

o

[MPA feedback L10]

Here, tell me the name of the novel protein, and the species from which it derives. It is
very unlikely (but still definitely possible) that you will find a novel gene from an
organism such as S. cerevisiae, human or mouse, because those genomes have
already been thoroughly annotated. It is more likely that you will discover a new gene in
agenome that is currently being sequenced, such as bacteria or plants or protozoa.

[Q4] Prove that this gene, and its corresponding protein, are novel. For the purposes of

this project, “novel” is defined as follows. Take the protein sequence (your answer to

[Q3)), and use it as a query in a blastp search of the nr database at NCBI.

 If there is a match with 100% amino acid identity to a protein in the database, from the
same species, then your protein is NOT novel (even if the match is to a protein with a
name such as “unknown”). Someone has already found and annotated this sequence,
and assigned it an accession number.

 If the top match reported has less than 100% identity, then it is likely that your protein
is novel, and you have succeeded

+ If there is a match with 100% identity, but to a different species than the one you
started with, then you have likely succeeded in finding a novel gene.

 If there are no database matches to the original query from [Q1], this indicates that
you have partially succeeded: yes, you may have found a new gene, but no, itis not
actually homologous o the original query. You should probably start over.

Q5] Generate a multiple sequence alignment with your novel protein, your original
query protein, and a group of other members of this family from different species. A
typical number of proteins to use in a multiple sequence alignment for this assignment
purpose is a minimum of 5 and a maximum of 20 - although the exact number is up to
you. Include the multiple sequence alignment in your report. Use Courier font with a size
appropriate to fit page width.

Side-note: Indicate your sequence in the alignment by choosing an appropriate name
for each sequence in the input unaligned sequence file (i.e. edit the sequence file so
that the species, or short common, names (ather than accession numbers) display in
the output alignment and in the subsequent answers below). The goal in this step is to
create an interesting an alignment for building a phylogenetic tree that ilustrates
species divergence

Find-a-Gene Project Assignment

A total of 20% of the course grade will be assigned based on the
“find-a-gene project assignment”

The objective with this assignment is for you to demonstrate your
grasp of database searching, sequence analysis, structure analysis
and the R environment that we have covered to date in class.

You may wish to consult the scoring rubric (in the linked project
description) and the example report for format and content
guidance.

= Your responses to questions Q1-Q4 are due at the beginning of
class Wed February 26th (02/26/20).

= The complete assignment, including responses to all questions,
is due at the beginning of class Wed March 11th (03/11/20).




What is Git?

(1) An unpleasant or contemptible
person. Often incompetent,
annoying, senile, elderly or
childish in character.

(2) A modern distributed version
control system with an emphasis
on speed and data integrity.

What is Git?

(1) An unpleasant or contemptible
person. Often incompetent,
annoying, senile, elderly or
childish in character.

(2) A modern distributed version
control system with an emphasis
on speed and data integrity.

Version Control

Version control systems (VCS) record changes
to a file or set of files over time so that you can
recall specific versions later.

Free/open-source CVS (1986, 1990 in C) - CVSNT (1998) - QVCS Enterprise (1998) - Subversion (2000)

Software Change Manager (1970s) - Panvalet (1970s) - Endevor (1980s) - Dimensions CM
Rt (1980s) - DSEE (1984) - Synergy (1990) - ClearCase (1992) - CMVC (1994) - Visual SourceSafe
Proprietary  (1994) - Perforce (1995) - StarTeam (1995) - Integrity (2001) - Surround SCM (2002) «
AccuRev SCM (2002) - SourceAnywhere (2003) « Vault (2003) - Team Foundation Server (2005)
Team Concert (2008)
GNU arch (2001) - Darcs (2002) - DCVS (2002) - ArX (2003) - Monotone (2003) « SVK (2003) -
Free/open-source X . X -
Distributed Codeville (2005) + Bazaar (2005) + Git (2005) - Mercurial (2005) « Fossil (2007) - Veracity (2010)

Proprietary TeamWare (1990s?) - Code Co-op (1997) + BitKeeper (1998) - Plastic SCM (2006)

There are many VCS avallable see:
iKi iki/Revision_control

Client-Server vs Distributed VCS

(-
O ... = //g
/ = W\
v\\~- - T - =
commit access g / g
/ code repository D./ l /
N s _
- =

Client-server approach Distributed approach

Distributed version control systems (DCVS) allows
multiple people to work on a given project without
requiring them to share a common network.




THE #1 PROGRAMMER EXCUSE
FOR LEGITIMATELY SLACKING OFF:

“The Subversion server’s down”

~(HEY! GETBAK Y

http://tinyurl.com/distributed-advantages

Where did Git come from?

Written initially by Linus Torvalds to
support Linux kernel and OS
development.

Meant to be distributed, fast and
more natural.

Capable of handling large projects.

Now the most popular free VCS!

Git is now the most popular free VCS!

THE #1 PROGRAMMER EXCUSE
FOR LEGITIMATELY SLACKING OFF:

“The Subversion server’s down” Git offers:
Speed
Backups
Off-line access
Small footprint
Simplicity*
Social coding

~(HEY! GETBAK Y

http://tinyurl.com/distributed-advantages

Why use Git?




Q. Would you write your Llab boolk in
pencil, then erase and overwrite it
every ciouj with new conbkent?

Why use Git?

Provides ‘snapshots’ of your project during development
and provides a full record of project history.

Allows you to easily reproduce and rollback to past
versions of analysis and compare differences. (N.B. Helps
fix software regression bugs!)

Keeps track of changes to code you use from others such
as fixed bugs & new features

Provides a mechanism for sharing, updating and
collaborating (like a social network)

Helps keep your work and software organized and available

Q. Would you write your Llab boolk in
pencil, then erase and overwrite it
every ciouj with new conbkent?

Version control is the lab notebook of the digital
world: it's what professionals use to keep track of
what they’ve done and to collaborate with others.

Obtaining Git




Note: You might already have git installed Note: You might already have git installed .
To check open the “Terminal” tab in RStudio and type : To check open the “Terminal” tab in RStudio and type

which git i 5 which git
® g | | ©) g

Obtaining Git

i Windows Only (if you have problems)
Did you install GitBash, instructions here:

i https://bioboot.github.io/bggn213 W20
If so try:

f where git

Then Restart RStudio

On a PC Only!

Go to: RStudio > Tools > Global Options > Terminal Note: You might already have git installed .
: To check open the “Terminal” tab in RStudio and type

which git
©) g

Options

General Shell

Make sure
Code New terminals open with: Git Bash 9 Git Bash is
selected!

- .
.J Appearance Connection

| Connect with WebSockets
Pane Layout

Miscellaneous

Packages . )
¥ Close terminal when shell exits

R Markdown

?) Using the RStudio terminal
@/~ Sweave

i Windows
% Spelling Follow the GitBash instructions here:
W susn ! hitps://bioboot.github.io/bggn213_S19/setu

GJ' Publishing

Tomnd i Mac & Linux

Download git directly from here:
! https://git-scm.com/downloads




: Note: You might already have git installed
;To check open the “Terminal” tab in RStudio and type:

which git

Install Git
Windows Configuring Git

Follow the GitBash instructions here:
https://bioboot.github.io/bimm143 S18/setu

Mac & Linux
Download git directly from here:

https://git-scm.com/downloads

Mac Install the Xcode command line tools (not all of Xcode):
xcode-select --install

Configuring Git
(RStudio Terminal Tab)
(...or RStudio > Tools > Shell)

# First tell Git who you are
> git config --global user.name “Barry Grant”
> git config --global user.email “bjgrant@ucsd.edu”




For Mac & Linux
(PC on next slide)

Go to: RStudio > Tools > Global Options > Git/SVN

Y] Enable version control interface for RStudio projects 1 Make sure l'h/S /S ticked/
2 Make sure this is correct!

] ]
Using Git _ S 1° 2
ance | Check in your RStudio “Tefminal” tab:

Console  Terminal Markdown

Terminal '~ | another
blitz: > which git
/usr/local/bin/git
blitz: >

7 Using Version Control with RStudio

1. Initiate a Git repository,
2. Edit content (iLe. change some files).
3, Store a ‘snapsho&' of the current file state.*

Create a new
RStudio project

1 New option to create
a Git repository...

2 New Git tab...
N\,

¥

1 Make sure this is ticked!
Environment  History  Connections GED

2 This is the PATH for PC! reseNowproieet
Directory name: 4 B Diff Commit Q-
) Test f Staged Status Path
Create project as gubdirectory of — . . . .gitignore
a B B test.Rproj

[¥I create a git repository

[TUse packrat with this project

Cancel

Check if new Git options appear in RStudio?




GitHub & Bitbucket

GitHub and Bitbucket are two popular hosting services for
Git repositories. These services allow you to share your
projects and collaborate with others using both ‘public’ and
‘private’ repositories”.

Creata -

$R 2D

O bioni /ot 0

- https://github.com - o https://bitbucket.or

a us.10Yr Crude Oil Yen m
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GitHub Raises $250 Million at $2 Billion
Valuation

Capital raise puts company's total funding at $350 million

|

Analytics

How does your organization’s
talent measure up

to its technology?
‘é ‘2
i AN €

Home = Video = World | US&Canada UK | Business Tech = Science | Stories = Entertainment&Ars | Health

Microsoft buys Github code-sharing site Top Stories
for $7.5bn Gangster 'Whitey' Bulger killed in

prison
£ Dave Lee Bulger was severely beaten by one or
North America technology reporter more inmates shortly after arriving at the
i/ 4 prison, sources say.

© 30 October 2018
© 4June2018 B « Share

Synagogue shooting victims'

funerals start

© 30 October 2018

‘What do American voters care
about?

© 30 October 2018

What is the big deal?

* At the simplest level GitHub and Bitbucket offer backup of
your projects history and a centralized mechanism for
sharing with others by putting your Git repo online.

* GitHub in particular is often referred to as the “nerds
FaceBook and LinkedIn combined”.

* At their core both services offer a new paradigm for open
collaborative project development, particularly for software.

* |In essence they allow anybody to contribute to any
public project and get acknowledgment.




First sign up for a GitHub account
https://github.co

GitHub Explore Features Enterprise ~Pricing Signin

Build software
better, together.

Powerful collaboration, code review, and code management for
open source and private projects. Public projects are always free.

Pick the FREE plan!

Pull requests  Issues  Gist

Welcome to GitHub

You've taken your first step into a larger world, @biobootStudent

Completed
Set up a per

([ See2

Choose your plan

Choose your personal plan

Plan Cost

Large $50/month

Medium  $22/month

Small $12/month

Micro S7/month

So/month

Each plan includes:

Private repositories
Unlimited collaborators

50
Unlimited public repositories

20
Free setup

10 HTTPS Protection
Email support

Wikis, Issues, Pages, & more

Your GitHub homepage

Check your email for verification request

Pull requests Issues  Gist

Pro tip: updating your profile with your name, location, and a profile picture helps other
GitHub users get to know you.

[ Contributions ] Repositories 3\ Public activity

Contributions

biobootStudent

Joined on Aug 26, 2015

This is your contribution graph. When you make a commit to a repository, you'll get a 1 for that
day. Make more contributions and you'll get a darker green square. Over time, your chart might
start looking something like this.

We have a quick guide that will show you how to create your first repository. You'll also make a
commit and earn your first green square!

EE Read the Hello World guide

Your email was verified

biobootStudent ~

Welcome to GitHub! What's next?
Create a rep
Yo

github on T

Pull requests  Issues  Gist

Your repositories

You don't

Create your first

ProTip! Feline cephalopod adhesives are great
for decorating portable computation devices.

Q ProTip! Edit your feed by updating the users you follow and repositories you watcs

) Subscribe to your news feed




Name your repo
bggn213

Pull requests Issues Marketplace Explore

Create a new repository

A repository contains all the files for your project, including the revision history.

Owner Repository name
L. bioboot ~ bggn213
Great repository names are short and memorable. Need inspiration? How about cuddly-invention

Description (optional)

Public

Anyone can see this repository. You choose who ca

Private

You choose who can see and commit to this repository

 Iniffalize this repository with a README

G will let you immediately clone the repository to your computer. Skip this step if you're importing an existing repository

Add gitignore: None ~ Add a license: None v @)

-

Eeeey* Create

Copy the “Clone” HTTPS link

o This repository ~ Search

bioboot / bimm143

Pull requests Issues Marketplace Explore

©Unwatch~ 1

<> Code Issues 0 Pull requests 0 Projects 0 Insights Settings

No description, website, or topics provided.

Add topics
© 1 commit
Branch: master~  New pull request

. bioboot Initial commit

E) README.md

README.md

bggn213

1 branch © Oreleases 21 1 contributor

Create new file  Upload files  Find filge [Nl ILIIIEELRS

Clone with HTTPS @ Use SSH

Use Git or checkout with SVN using the web URL.
Initial commit

https://github.con/bioboot/binm143.gif [

Open in Desktop Download ZIP

RStudio > New Project > Version Control

New Project

Create Project

New Directory
Start a project in a brand new working directory

Existing Directory
Associate a project with an existing working directory

Version Control
Checkout a project from a version control repository

Cancel

RStudio > New Project > Version Control

New Project

Back

v/Open in new session

Clone Git Repository

Repository URL: GitHub
https://github.com/bioboot/bggn213.git Paste

Project directory name:
bggn213_github

Create project as subdirectory of:
~/Desktop/courses/bggn213_S18 Browse...

Create Project Cancel




Demo of editing, adding Demo of editing, adding
committing and pushing committing and pushing

Check if new Git tab Check if new Git tab
Appears in RStudio? Appears in RStudio?

Now experiment editing the
Environment  History ~ Connections = Git_ Environment  History ~ Connections = Git_ README.md file in RStudio
B Diff Commit O -1 Now experiment editing the B Diff Commit O -1 and adding, committing and

Staged Status Path README.md file in RStudio Staged Status Path pushing changes to GitHub

@ @@ gignore and adding, committing and @ BB giignore via this tab

@ BEE testRproj pushing changes to GitHub @ BEE testRproj
\ERGLIERE]

When you are ready copy your
different class directories/projects
to this new GitHub tracked folder

Side-note: How to edit online

Specifically lets add some Markdown content

Enable passwd-less push and pull to GitHub:

http://tinyurl.com/rclass-github

Step 1B only please!
(We have already done steps 1A and 2 to 5)




Summary Learning Resources

o e , . Set up Git. If you will be using Git mostly or entirely via
» Gitis a popular ‘distributed’ version control GitHub, 100k at these how-tos.

system that is lightweight and free < https://help.github.com/categories/bootcamp/ >

. G|’[|—|ub and BitBucket are popu|ar hosting Getting Git Right. Excellent Bitbucket git tutorials
services for git repositories that have changed the < hllps www allassian Com/git/ >
way people contribute to open source projects

Pro Git. A complete, book-length guide and reference to Git,
by Scott Chacon and Ben Straub.
* Introduced basic git and GitHub usage within < http://git-scm.com/book/en/v2 >

RStudio and encouraged you to adopt these ‘best
practices’ for your future projects.

StackOverflow. Excellent programming and developer Q&A.
< http://stackoverflow.com/questions/tagged/git >

Learning git can be painful!

However in practice it is not nearly as crazy-making as

the alternatives: Finally Please remember that GitHub

Documents as email attachments and BitBucket are PUBLIC and that
Hair-raising ZIP archives containing file salad you should cultivate your professional

and scholarly profile with intention!
Am | working with the most recent data?

Archaelogical “digs” on old email threads and
uncertainty about how/if certain changes have been
made or issues solved




[ Muddy Point Assessment ]

Using Command Line Git

1. Initiate a Git reposi.&orj.
2. Edit content (iLe. change some files).
3. Store a ‘snapshot’ of the current file state.*

Reference Slides

Initiate a Git repository




Side-Note: The .git/ directory

Git created a ‘hidden’ .git/ directory inside your
current working directory.

Initiate a G |t e pOSltOry You can use the ‘Is -a’ command to list (i.e. see)

this directory and its contents.
> cd ~/Desktop

> mkdir git_class # Make a new directory This is where Git stores all its goodies - this is Git!
> cd git_class # Change to this directory
> git init # Our first Git command!
> s -a # what happened?

You should not need to edit the contents of the .git
directory for now but do feel free to poke around.

Important Git commands Important Git commands

> git add <filename>  # stage/track a file > git add <filename>  # stage/track a file
> git commit -m “message” # snapshot > git commit -m “message” # snapshot

> git status # report on content changes > git status # report on content changes )

You will use these three commands again and again in your Git workflow!




Git TRACKS your directory content Example Git workflow

» To get a report of changes (since last commit) use:
> git status Eva creates a README text file
(this starts as untracked)

* You tell Git which files to track with:
> git add <filename> Adds file to STAGING AREA*

This adds files to a so called STAGING AREA (tracked and ready to take a snapshot)

(akin to a “shopping cart” before purchasing).

Commit changes*

* You tell Git when to take an historical SNAPSHOT of (records Snapshot of Staged f||es|)
your staged files (i.e. record their current state) with:

> git commit -m ‘Your message about changes’

Example Git workflow 1. Eva creates a README file

Eva creates a README text file # cd ~/Desktop/git_class
# git init

echo "This is a first line of text." > README
git status # Report on changes

Adds file to STAGING AREA*

Commit changes #0n branohEnEéEgﬂ

#
# Initial commit
#
#

,@ntracked files:}
# (USegit add <file>..." to include in what will be committed)

Eva modifies README and adds a ToDo text file
N

@ Adds both to STAGING AREA*
Commit changes*

# nothing added to commit but untracked files present (use "git add" to track)




2. Adds to ‘staging area’

> gitadd README  # Add README file to staging area
> git status # Report on changes

# On branch master
#

# Initial commit

#
#{Changes to be committed:

# (use 'git rm --cached <file>..." to unstage)
#

new file: README
#

4. Eva modifies README file
and adds a ToDo file

> echo "This is a 2nd line of text." >> README
> echo "Learn git basics" >> ToDo

> git status # Report on changes

# On branch master
#
# Changes not staged for commit:
(use "git add <file>..." to update what will be committed)
(use "git checkout -- <file>..." to discard changes in working directory)

modified:

#
#
#
#
# Untracked files:

# (use 'git add <file>..." to include in what will be committed)
#

#

#

#

no changes added to commit (use "git add" and/or "git commit -a")

3. Commit changes

> git commit -m “Create a README file” # Take snapshot
# [master (root-commit) 8676840] Create a README file

# 1 file changed, 1 insertion(+)

# create mode 100644 README

> git status # Report on changes

# On branch master
# nothing to commit, working directory clean

5. Adds both files to ‘staging area’

> git add README ToDo # Add both files to ‘staging area’

> git status # Report on changes

# On branch master
# Changes to be committed:
(use "git reset HEAD <file>..." to unstage)

modified: README
new file: ToDo




6. Commits changes

> git commit -m "Add ToDo and modify README"

# [master 7b679fa] Add ToDo and modify README
# 2 files changed, 2 insertions(+)
# create mode 100644 ToDo

> git status

# On branch master
# nothing to commit, working directory clean

git log: Timeline history of
snapshots (i.e. commits)

> git log

# commit 7b679fa747e8640918fcaad7e4c3f9c70c87b170
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:43:40 2015 -0400

#

# Add ToDo and finished README

#

# commit 86768401610770ae32e2fd4faece07d1d5¢c68619¢
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:26:40 2015 -0400

#

# Create a README file

#

1.
2.

Example Git workflow

Eva creates a README text file

Adds file to STAGING AREA*

Commit changes*

...But, how do we see the history of our project changes?

git log: Timeline history of
snapshots (i.e. commits)

> git log

# commit 7b679fa747e8640918fcaad7e4c3f9c70c87b170
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:43:40 2015 -0400

#

# Add ToDo and finished README

#

# commit 86768401610770ae32e2fd4faece07d1d5¢c68619¢
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:26:40 2015 -0400

#

# Create a README file

#




Side-Note: Git history is akin
to a graph

Nodes are commits labeled by their
unique ‘commit ID’.

(This is a CHECKSUM of the commits
author, time, commit msg, commit content
and previous commit ID).

HEAD is a reference (or ‘pointer’) to the
currently checked out commit (typically the
most recent commit).

Projects can have complicated
graphs due to branching

Master Feature BugFix

5906. ..
1g9Kk...

8.6.../

Branches allow you to work independently
of other lines of development we will talk
more about these later!




Summary of key Git commands:

> git status # Get a status report of changes since last commit

> git add <filename> # Tell Git which files to track/stage

> git commit -m ‘Your message’ # Take a content snapshot!

> git log # Review your commit history

> git diff <commit.ID> <commit.ID> # Inspect content differences

> git checkout <commit.ID> # Navigate through the commit history

git diff: Show changes
between commits

> git diff 8676 7b67

# diff --git a/README b/README
# index 73bc85a..67bd82c 100644
# --- a/README

# +++ b/README

#Q@@-1+12 @@

# This is a first line of text.

# +This is a 2nd line of text.

# diff --git a/ToDo b/ToDo
# new file mode 100644

# index 0000000..14fbd56
# --- /dev/null

# +++ b/ToDo

# @@ -0,0 +1 @@

# +Learn git basics

‘Staging  Local
Area’ Repository

O—
" status O

O—

git diff: Show changes
between commits

> git diff 7b67 8676

# diff --git a/README b/README
# index 67bd82c..73bc85a 100644
# --- a/README

# +++ b/README

#Q@@-1,2 +1 @@

# This is a first line of text.

#

# diff --git a/ToDo b/ToDo

# deleted file mode 100644
# index 14fbd56..0000000
# --- a/ToDo

# +++ /dev/null

#@@ 1 +0,0 @@

#




git diff: Show changes
between commits

> git diff 8676 ## Difference to current HEAD position!
# diff --git a/README b/README

# index 73bc85a..67bd82c 100644 *

# --- a/README

# +++ b/README m 7687 ...
#e@-1+120@

# This is a first line of text.
# +This is a 2nd line of text.

# diff --git a/ToDo b/ToDo
# new file mode 100644

# index 0000000..14fbd56 8.6 i
# --- /dev/null

# +++ b/ToDo

# @@ -0,0 +1 @@
# +Learn git basics

git checkout: Moves HEAD

> more README
This is a first line of text.
This is a 2nd line of text.

> git log --oneline
# 7b679fa Add ToDo and finished README
# 8676840 Create a README file

HEAD advances automatically with

each new commit

m 7‘7- - To move HEAD (back or forward)

on the Git graph (and retrieve the
associated snapshot content) we
can use the command:

> git checkout <commit.ID>

8@6...

git checkout: Moves HEAD
(e.g. back in time)

> more README
This is a first line of text.
This is a 2nd line of text.

> git log --oneline
# 7b679fa Add ToDo and finished README
# 8676840 Create a README file

> git checkout 86768
# You are in 'detached HEAD' state...<cut>...
# HEAD is now at 8676840... Create a README file

> more README
This is a first line of text.

> git log --oneline
# 8676840 Create a README file




git checkout: Moves HEAD
(e.g. back to the future!)

> git checkout master
# Previous HEAD position was 8676840... Create a README file
# Switched to branch ‘master’

> git log --oneline m 7‘7
# 7b679fa Add ToDo and finished README "'

# 8676840 Create a README file

> more README
This is a first line of text.
This is a 2nd line of text.

You can discard revisions
with git revert

* The git revert command undoes a committed
snapshot.

» But, instead of removing the commit from the
project history, it figures out how to undo the
changes introduced by the commit and appends
a new commit with the resulting content.

> git revert <commit.ID>

* This prevents Git from losing history!

8@6. ..

Side-Note: There are two* main ways to

use git checkout

Checking out a commit makes the entire working
directory match that commit. This can be used to
view an old state of your project.

> git checkout <commit.ID>
Checking out a specific file lets you see an old
version of that particular file, leaving the rest of

your working directory untouched.

> git checkout <commit.ID> <filename>

Removing untracked files
with git clean

The git clean command removes untracked files from
your working directory.

Like an ordinary rm command, git clean is not
undoable, so make sure you really want to delete the
untracked files before you run it.

> git clean -n # dry run display of files to be ‘cleaned’

> git clean -f # remove untracked files




https:

Tower (Mac only)
GitHub_Desktop (Mac, Windows)
SourceTree (Mac, Windows)
SmartGit (Linux)
RStudio

it-scm.com/downloads/quis




