HOW TO ENCOURA

Growth Mindset
What to say:

“When you leam
haw to do a new kind of
problem, it grows your math
bran!”

“If you catch yoursell
saying, I'm not a math
person,’ just add the word
yet' to the end of the
sentence.

“That feeling

of math being hard i3
the feeling ol your brain
growing.’

“The point
isn't to get it all nght
away. The point is to grow
your understanding step
by step. What can you try

nexi?”

GE STUDENTS

Fixed Mindset
What not to say:

“Not everybody is
geod at math. Just do your
best!

“That’s OK, mayhe
math is nat one of your
strengths.’

‘Deon‘t worry, you'll get it

*

il you keep tving”

*If studemts are uzing the wrong

sirategies, their ettorts might not work.

Plus they may feel particu'arly inept if

their efforts arm fniitless.

“Great effort!
You tried your best.™

*Don't accep:t less than optim2

performance from your students,

'CE: Carol Dwecx

Side-Note:

Replace "math” with "R
programing” to help reframe
your self criticism when
learning...
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http://thegrantlab.org/bimm143

Recap From Last [Iime:

Why it Is Important to visualize data during exploratory data
EWSIS)

Discussed data visualization best practices and how good
visualizations optimize for the human visual system.

Introduced the extensive graphical capabilities of base R
with a focus on generating and customizing scatterplots,
histograms, bar graphs, boxplots, (dendrograms and
heatmaps).

Use the par() function to control fine grained details of the
afore mentioned plot types.

Stoped hands-on session at section 2C
[IMPA Link]



https://docs.google.com/forms/d/e/1FAIpQLSdWlHtEtvO03iK8H_CNjSzvgGrqkkSr4GyCVpE1xNz0KvyBww/viewanalytics

Today's Learning Goals

- Last days R visualization hands-on exercise 4 revisited...
* Understanding, using and improving someone else function

- More on data import
* File pre-check recommendations
e Using read.table() and friends for flat files

- Writing your own functions
* What, Why, When and How

Hands-on session
* Practice, tips, techniques for troubleshooting, and best
practice guidelines for writing and debugging your functions
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Class 5 Revisited

* Open your previous class05 RStudio project
(and your saved R script)

» Can you source this class05.R ftile to re-generate
all your plots without error? N\

@ M | WsSourceonSave ® .

* |f so you can now generate a nice HTML report
of your work to date...

[ Take 2-3 minutes]



Exercise 4 Revisited

 Locate and open in RStudio the downloaded file
color_to_value_map.r

* This is an example of a poorly written function
typical of something you might get from a lab
mate that knows some R...

[ Take 2-3 minutes]



(POOR!) Color Mapping Function

map.colors <- function (value,high.low,palette) {
proportion <- ((value-high.low[1l])/ (high.low[2]-high.low[1]))
index <- round ((length (palette)-1) *proportion)+1
return (palette[index])

Talking points:
Can you figure out what this function it is supposed to do?

What format should the inputs be in order to work?
How could we improve this function?




1. What are the function inputs?

map.colors2 <- function(x, high.low, palette) {
proportion <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))
index <- round( (length(palette)-1) * proportion )+1

return (palette[index])

J

Let’s first space things out so it is easier for us to read and then

change to use as our numeric input vector.




1. What are the function inputs?

map.colors2 <- function(x, high.low, palette) {
proportion <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))
index <- round( (length(palette)-1) * proportion )+1

return (palette[index])

J

Let’s first space things out so it is easier for us to read and then
change to use as our numeric input vector.

We can guess that Is a two element numeric vector
and palette is probably a vector of colors




2. What is the function doing?

map.colors2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
proportion <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

index <- round( (length(palette)-1) * proportion )+1

return (palette[index])

Let’s add a to explain the logic of the first line




2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

index <- round( (length(palette)-1) * precent )+1

return (palette[index])

J

Let’s change the object name from proportion to soitis

more meaningful for us. Remember to change it everywhere ;-)




2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

#index <- round( (length (palette)-1) * precent )+1
index <- round( length(palette) * precent )

return (palette[index])

Perhaps we can simplify the next line, which determines the

corresponding index position in the color '‘palette' vector?




2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

#index <- round( (length (palette)-1) * precent )+1
index <- round( length (palette) * precent )

return (palette[index])

Doh! What happens if our precent value is zero or very small?

We will get an value of zero, will cause a problem when
accessing palette] ] In the last line




2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

# Find corresponding index position in the color ‘palette’
i note catch for 0 precent values to 1

index <- round( (length (palette)-1) * precent )+1

return (palette[index])

Add a comment again to describe the logic of what our code is doing




3. How could we improve this function?

map.colors?2 <- function(x, high.low, palette) {

## Description: Map the values of the input vector 'x'
## to the input colors vector ‘palette'

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

# Find corresponding index position in the color ‘palette’
# note catch for 0 precent values to 1

index <- round( (length (palette)-1) * precent )+1

return (palette[index])

Make more user friendly in lots of ways including adding description,

iInput argument defaults, error checking of inputs, tests, etc.



3. How could we improve this function?

map.colors3 <- function (x,
low.high

palette

range (x),
cm.colors (100)) {

## Description: Map the values of the input vector 'x'
## to the input colors vector ‘palette'

# Determine precent values of the 'high.low' range
precent <- ((x - low.high[2])/ (low.high[l] - low.high[2]))

# Find corresponding index position in the color ‘palette’
i note catch for 0 precent values to 1

index <- round( (length(palette)-1) * precent )+1

return (palette[index])

Make more user friendly in lots of ways including adding description,

iInput argument defaults, error checking of inputs, tests etc.



Today's Learning Goals

- Last days R visualization hands-on exercise 2C revisited...
* Understanding, using and improving someone else function

- More on data import

* File pre-check recommendations
e Using read.table() and friends for flat files

- Writing your own functions
* What, Why, When and How

 Hands-on session
* Practice, tips, techniques for troubleshooting, and best
practice guidelines for writing and debugging your functions



Pre-check recommendations

* Get organized!
e Start a new ‘project’ in a directory you know about and store
all needed project material here (input, scripts and output).
* In RStudio File > New Project > New Directory > ...



Pre-check recommendations

* Get organized!
e Start a new ‘project’ in a directory you know about and store
all needed project material there (input, scripts and output).
* In RStudio File > New Project > New Directory > ...

* Inspect the file

* Open it from the RStudio Files tab.

* Does it have a header line or comments to be included,
ignored or removed?

e Avoid file (or field names) with spaces or special characters
suchas?, $,%, N, & *, } etc.

e Short names are preterred over longer names.

e Does the file end with a blank line or a RTN?



read.table() and friends for flat files

- The read.table() function is the base of all flat file import functions

e read.delim(“filename.txt”, sep="“\t") TAB

e read.csv(“filename.txt”, sep="-,") COMMA

* read.csv2(“filename.txt”, sep="") SEMI-COLON
* read.table(“filename.txt”, sep="") WHITE SPACE

- What other differences are there between these functions?

« MS EXCEL file import options include:
e Export (i.e. “Save As...”) your excel data to plain text CSV format.
* Or if you must, use readxl::read_excel() to read specified parts of your sheets.

* For fast and convenient reading of very large flat files files
 Try data.table::fread() use is similar to read.table() but it automatically finds
field separators and header rows. It is also much faster!

« Saving and loading .RData files...

e Use the functions save() and load() for saving and loading multiple objects to
space efficient binary format files.



Your turn!

https://bioboot.github.io/bimm143_S18/class-material/testi .txt
https://bioboot.github.io/bimm143_S18/class-material/test?.txt

https://bioboot.github.io/bimm143 S18/class-material/test3.txt

e Start a new RStudio Project in a clean directory

 Open a new Rmarkdown document and give it a
name and descriptive text.

e Download each of the above files and move them
iInto your Project

 Experiment with read.table() to get their data
successfully input into your R session.


https://bioboot.github.io/bimm143_S18/class-material/test1.txt
https://bioboot.github.io/bimm143_S18/class-material/test2.txt
https://bioboot.github.io/bimm143_S18/class-material/test3.txt

Today's Learning Goals

- Last days R visualization hands-on exercise 2C revisited...
* Understanding, using and improving someone else function

- More on data import
* File pre-check recommendations
e Using read.table() and friends for flat files

- Writing your own functions
* What, Why, When and How

 Hands-on session
* Practice, tips, techniques for troubleshooting, and best
practice guidelines for writing and debugging your functions



What Is a function

‘ Name (can be almost anything you want )
‘ Arguments (i.e. input to your function)

‘ Body (where the work gets done)



What Is a function

‘ Name ( in this case “add” )
‘ Arguments (here “x” and “y")

‘ Body (will return the result of the last statement)



Your function is treated just
Ike any other function...




Why would you write a
function

When you find yourself doing the same thing 3 or
more times it is time to write a function.




Why would you write a
function

When you find yourself doing the same thing 3 or
more times it is time to write a function.




Why would you write a
function

Consider the advantages:

 Makes the purpose of the code more clear
* Reduce mistakes from copy/paste
 Makes updating your code easer
 Reduce duplication and facilitate re-use.




How would you write this
function

Start with a working code snippet, simplity, reduce
calculation duplication,...
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How would you write this
function

Start with a working code snippet, simplify, reduce
calculation duplication,...




How would you write this
function

Start with a working code snippet, simplity, reduce
calculation duplication, finally turn it into a function




How would you write this
function

Test, Fail, Change, Test again,...




Side-Note: Seeing and using
your function in RStudio

* An easy way to visualize the code of a function is to
type its name without the parentheses ().

 |f you have your new function saved to a separate file
then you can load and execute It using
the source() function. E.g. source("MyUtils.R")

* The return() statement is not required in a function but
it Is advisable to use it when the function performs
several computations. It has the eftect of ending the
function execution and returning control to the code
which called it.









Today's Learning Goals

- Last days R visualization hands-on exercise 2C revisited...
* Understanding, using and improving someone else function

- More on data import
* File pre-check recommendations
e Using read.table() and friends for flat files

- Writing your own functions
* What, Why, When and How

Hands-on session
* Practice, tips, techniques for troubleshooting, and best

practice guidelines for writing and debugging your functions




Your turn!

https://bioboot.github.io/bimmi143_F18/lectures/#6

Concentrate on Section 1B and guestions 1 to 6.
Other sections are there for your benetfit.

[Also aim to generate a HTML report from your R script]


https://bioboot.github.io/bimm143_F18/lectures/#6




Homework!

New DataCamp Assignments

* Functions
* Loops
* Your lectureb function homework

Muddy Point Assessment Form Link



https://goo.gl/forms/i5FWaVxlwb4Vxyim1
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