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function()

Last class!



Last class revisited...
• Write a function grade() to determine an overall 

grade from a vector of student homework 
assignment scores dropping the lowest single 
assignment score.

# student 1
c(100, 100, 100, 100, 100, 100, 100, 90)

# student 2
c(100, NA, 90, 90, 90, 90, 97, 80)

# now grade all students in an example class
url <- "https://tinyurl.com/gradeinput"

Last class!



Last class revisited...
• Write a function grade() to determine an overall 

grade from a vector of student homework 
assignment scores dropping the lowest single 
assignment score.

Last class!

grade <- function(x) {
  x <- as.numeric(x)
  x[ is.na(x)] = 0
  mean(x[ -which.min(x) ])
}
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grade <- function(x) {
  x <- as.numeric(x)
  x[ is.na(x)] = 0
  mean(x[ -which.min(x) ])
}

Last class revisited...
• Write a function grade() to determine an overall 

grade from a vector of student homework 
assignment scores dropping the lowest single 
assignment score.

Last class!



Do this now…
• Write a function grade2() to determine an overall 

grade from a vector of student homework 
assignment scores OPTIONALLY dropping the 
lowest single assignment score.

Last class!

grade <- function(x) {
  x <- as.numeric(x)
  x[ is.na(x)] = 0
  mean(x[ -which.min(x) ])
}



Last class revisited...
Last class!

grade2 <- function(x, drop.lowest=TRUE) {
  x <- as.numeric(x)
  x[ is.na(x)] = 0
  if(drop.lowest) {
    mean(x[ -which.min(x) ])
  } else {
    mean(x)
  }
}



And some function homework….
Complete Q6. In last days lab supplement 



library(bio3d)
s1 <- read.pdb("4AKE")  # kinase with drug
s2 <- read.pdb("1AKE")  # kinase no drug
s3 <- read.pdb("1E4Y")  # kinase with drug

s1.chainA <- trim.pdb(s1, chain="A", elety="CA")
s2.chainA <- trim.pdb(s2, chain="A", elety="CA")
s3.chainA <- trim.pdb(s1, chain="A", elety="CA")

s1.b <- s1.chainA$atom$b
s2.b <- s2.chainA$atom$b
s3.b <- s3.chainA$atom$b

plotb3(s1.b, sse=s1.chainA, typ="l", ylab="Bfactor") 

plotb3(s2.b, sse=s2.chainA, typ="l", ylab="Bfactor") 

plotb3(s3.b, sse=s3.chainA, typ="l", ylab="Bfactor")

Your Homework!



Suggested steps for writing 
your functions 

1. Start with a simple problem and get a working snippet of code 


2. Rewrite to use temporary variables (e.g. x, y, df, m etc.)


3. Rewrite for clarity and to reduce calculation duplication


4. Turn into an initial function with clear useful names


5. Test on small well defined input and (subsets of) real input 


6. Report on potential problem by failing early and loudly! 


7. Refine and polish   





What is Git?
(1)  An unpleasant or contemptible 

person. Often incompetent, 
annoying, senile, elderly or childish 
in character.


(2) A modern distributed version 
control system with an emphasis 
on speed and data integrity.



(1)  An unpleasant or contemptible 
person. Often incompetent, 
annoying, senile, elderly or childish 
in character.


(2) A modern distributed version 
control system with an emphasis 
on speed and data integrity.

What is Git?



Version Control
Version control systems (VCS) record changes to 

a file or set of files over time so that you can 
recall specific versions later.

There are many VCS available, see:
https://en.wikipedia.org/wiki/Revision_control

https://en.wikipedia.org/wiki/Revision_control


Client-Server vs Distributed VCS 

Distributed version control systems (DCVS) allows 
multiple people to work on a given project without 

requiring them to share a common network.

Client-server approach Distributed approach



http://tinyurl.com/distributed-advantages

http://tinyurl.com/distributed-advantages


http://tinyurl.com/distributed-advantages

Git offers:

• Speed

• Backups

• Off-line access

• Small footprint

• Simplicity*

• Social coding

Git is now the most popular free VCS!

http://tinyurl.com/distributed-advantages


Where did Git come from?
Written initially by Linus Torvalds to 
support Linux kernel and OS 
development.


Meant to be distributed, fast and more 
natural.


Capable of handling large projects.


Now the most popular free VCS!





Why use Git?



Q. Would you write your lab book in

   pencil, then erase and overwrite it

   every day with new content?



Q. Would you write your lab book in

   pencil, then erase and overwrite it

   every day with new content?

Version control is the lab notebook of the digital 
world: it’s what professionals use to keep track of 
what they’ve done and to collaborate with others. 



Why use Git?
• Provides ‘snapshots’ of your project during development and 

provides a full record of project history.


• Allows you to easily reproduce and rollback to past versions of 
analysis and compare differences. (N.B. Helps fix software 
regression bugs!)


• Keeps track of changes to code you use from others such as 
fixed bugs & new features 


• Provides a mechanism for sharing, updating and collaborating 
(like a social network)


• Helps keep your work and software organized and available



Obtaining Git



Obtaining Git

Note:  You hopefully already have git installed!

To check open the “Terminal” tab in RStudio and type:


     which git

     git --version 

1

2
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To check open the “Terminal” tab in RStudio and type:


     which git

     git --version 

1

2



Obtaining Git

Class Computer Setup Page

Windows Only (if you have problems)   

 

If the “which git” command did not work, try: 

where git


If this works see next slide. If not then you 
need to install GitBash, instructions here:

Note:  You might already have git installed

To check open the “Terminal” tab in RStudio and type:


     which git

     git --version 

1

2

xcode-select --install

Mac Only (if you have problems)   

 

If the “which git” command did not work, you 
may need to install select developer tools. 


In your Terminal type:

https://git-scm.com/downloads
https://git-scm.com/downloads


Obtaining Git

1

2

https://bioboot.github.io/bggn213_S19/setup/

Windows Only (if you have problems)   
Did you install GitBash, instructions here:

 

If so try: 

where git


Then Restart RStudio

RStudio > Tools > Global Options > TerminalGo to:
On a PC Only!

Make sure 
Git Bash is 
selected!

Then Restart RStudio

https://bioboot.github.io/bggn213_S19/setup/
https://git-scm.com/downloads


xcode-select --install

Installing Git

Class Computer Setup Page

Windows (if you have problems)   
Follow the GitBash instructions here:

Mac (if you have problems)  
In the Terminal instal select developer tools

Do it Yourself!Note:  You might already have git installed

To check open the “Terminal” tab in RStudio and type:


     which git

     git --version 

1

2



Configuring Git



Configuring Git

# First tell Git who you are 

> git config --global user.name  “Barry Grant” 

> git config --global user.email  “bjgrant@ucsd.edu”


Do it Yourself!

(RStudio Terminal Tab)

(…or RStudio > Tools > Shell)



Configuring RStudio



For Mac & Linux

(PC on next slide)

RStudio > Tools > Global Options > Git/SVN

1

Go to:

Make sure this is ticked!
Make sure this is correct!2

Check in your RStudio “Terminal” tab:

Do it Yourself!



On a PC!
RStudio > Tools > Global Options > Git/SVN

1

Go to:

This is the PATH for PC!2
Check in your Windows File Explorer:

Make sure this is ticked!

Do it Yourself!



Restart RStudio!



Using Git



Using Git
1. Initiate a Git repository.

2. Edit content (i.e. change some files).

3. Store a ‘snapshot’ of the current file state.*



Create a new Test 

RStudio project

 Check if new Git options appear in RStudio?

New Git tab…
New option to create 

a Git repository…

1
2

Do it Yourself!



Using Git in RStudio

1. Initiate a git repository for an RStudio Project 


2. Do your work and edit content as normal


3. Periodically add important files to git “Staging Area”


4. Commit changes to your “git repository”


      Rinse and repeat….    



Demo:

Follow along!



GitHub & Bitbucket
GitHub and Bitbucket are two popular hosting services for 
Git repositories. These services allow you to share your 
projects and collaborate with others using both ‘public’ and 
‘private’ repositories*.

https://github.com https://bitbucket.org

https://github.com
https://bitbucket.org






What is the big deal?

• At the simplest level GitHub and Bitbucket offer backup of 
your projects history and a centralized mechanism for 
sharing with others by putting your Git repo online. 


• GitHub in particular is often referred to as the “nerds 
FaceBook and LinkedIn combined”. 


• At their core both services offer a new paradigm for open 
collaborative project development, particularly for software.


• In essence they allow anybody to contribute to any public 
project and get acknowledgment.                     



First sign up for a GitHub account
https://github.com

https://github.com


Pick the FREE plan!



Your GitHub homepage
Check your email for verification request



Connecting RStudio to 
GitHub

Create a Personal Access Token (PAT) on GitHub

See section 4 of lab worksheet



Skip the hello-world tutorial
https://guides.github.com/activities/hello-world/

https://guides.github.com/activities/hello-world/


Name your repo 

bimm143

Add a  
README

Create

bggn213bimm143



Copy the “Clone” HTTPS link

bggn213



RStudio > New Project > Version Control



RStudio > New Project > Version Control

GitHub 
Pastebimm143.git

bimm143_github

bimm143



Demo of editing, adding 
committing and pushing

 Check if new Git tab 

Appears in RStudio?

Now experiment editing the  
README.md file in RStudio  
and adding, committing and 
 pushing changes to GitHub  

via this tab



Demo of editing, adding 
committing and pushing

 Check if new Git tab 

Appears in RStudio?

Now experiment editing the  
README.md file in RStudio  
and adding, committing and 
 pushing changes to GitHub  

via this tab

When you are ready copy your 
different class directories/projects 
to this new GitHub tracked folder



Side-note: How to edit online
Specifically lets add some Markdown content



Summary
• Git is a popular ‘distributed’ version control 

system that is lightweight and free


• GitHub and BitBucket are popular hosting 
services for git repositories that have changed the 
way people contribute to open source projects


• Introduced basic git and GitHub usage within 
RStudio and encouraged you to adopt these ‘best 
practices’ for your future projects. 



Learning Resources
• Set up Git. If you will be using Git mostly or entirely via 

GitHub, look at these how-tos. 

< https://help.github.com/categories/bootcamp/ >


• Getting Git Right. Excellent Bitbucket git tutorials

< https://www.atlassian.com/git/ >


• Pro Git. A complete, book-length guide and reference to Git, 
by Scott Chacon and Ben Straub.


< http://git-scm.com/book/en/v2 >


• StackOverflow. Excellent programming and developer Q&A.

< http://stackoverflow.com/questions/tagged/git >

https://help.github.com/categories/bootcamp/
https://www.atlassian.com/git/
http://git-scm.com/book/en/v2
http://stackoverflow.com/questions/tagged/git


Learning git can be painful!
However in practice it is not nearly as crazy-making as 
the alternatives:


• Documents as email attachments


• Hair-raising ZIP archives containing file salad


• Am I working with the most recent data?


• Archaelogical “digs” on old email threads  and 
uncertainty about how/if certain changes have been 
made or issues solved



Finally Please remember that GitHub 
and BitBucket are PUBLIC and that 
you should cultivate your professional 

and scholarly profile with intention!
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Using Command Line Git

1. Initiate a Git repository.

2. Edit content (i.e. change some files).

3. Store a ‘snapshot’ of the current file state.*



Initiate a Git repository



Initiate a Git repository
> cd ~/Desktop 

> mkdir git_class  # Make a new directory

> cd git_class       # Change to this directory

> git init               # Our first Git command!

> ls -a                   # what happened? 

Do it Yourself!



Side-Note: The .git/ directory

• Git created a ‘hidden’ .git/ directory inside your 
current working directory.


• You can use the ‘ls -a’ command to list (i.e. see) 
this directory and its contents.


• This is where Git stores all its goodies - this is 
Git!


• You should not need to edit the contents of the .git 
directory for now but do feel free to poke around.



Important Git commands
> git status      # report on content changes 


> git add <filename>    # stage/track a file

> git commit  -m “message”   # snapshot



Important Git commands
> git status      # report on content changes 


> git add <filename>    # stage/track a file

> git commit  -m “message”   # snapshot

You will use these three commands again and again in your Git workflow!



Git TRACKS your directory content

• To get a report of changes (since last commit) use:

    > git status


• You tell Git which files to track with:

    > git add <filename>

   This adds files to a so called STAGING AREA 

   (akin to a “shopping cart” before purchasing).


• You tell Git when to take an historical SNAPSHOT of 
your staged files (i.e. record their current state) with:


    >   git commit -m ‘Your message about changes’



Eva creates a README text file

(this starts as untracked)


Adds file to STAGING AREA*

(tracked and ready to take a snapshot)


Commit changes*

(records snapshot of staged files!)


Example Git workflow



Example Git workflow
• Eva creates a README text file


• Adds file to STAGING AREA*


• Commit changes*


• Eva modifies README and adds a ToDo text file


• Adds both to STAGING AREA*


• Commit changes*


Hands on example!



1.  Eva creates a README file

> # cd ~/Desktop/git_class

> # git init


> echo "This is a first line of text." > README    

> git status           # Report on changes 

# On branch master

# 

# Initial commit

#

# Untracked files:

#   (use "git add <file>..." to include in what will be committed)

#

#	 README

#

# nothing added to commit but untracked files present (use "git add" to track)

Do it Yourself!



2.  Adds to ‘staging area’

> git add README      # Add README file to staging area

> git status                  # Report on changes 

# On branch master

# 

# Initial commit

#

# Changes to be committed:

#   (use "git rm --cached <file>..." to unstage)

#

# 	 new file:   README

#




3.  Commit changes

> git commit -m “Create a README file”     # Take snapshot

# [master (root-commit) 8676840] Create a README file

#  1 file changed, 1 insertion(+)

#  create mode 100644 README


> git status                  # Report on changes 

# On branch master

# nothing to commit, working directory clean




4.  Eva modifies README file 

and adds a ToDo file

> echo "This is a 2nd line of text." >> README    

> echo "Learn git basics" >> ToDo    


> git status           # Report on changes 

# On branch master

#

# Changes not staged for commit:

#   (use "git add <file>..." to update what will be committed)

#   (use "git checkout -- <file>..." to discard changes in working directory)

#

#	 modified:   README

#

# Untracked files:

#   (use "git add <file>..." to include in what will be committed)

#

#	 ToDo

#

# no changes added to commit (use "git add" and/or "git commit -a")



5.  Adds both files to ‘staging area’

> git add README ToDo    # Add both files to ‘staging area’  

> git status                          # Report on changes 

# On branch master

# Changes to be committed:

#   (use "git reset HEAD <file>..." to unstage)

#

#	 modified:   README

#	   new file:   ToDo

#




6.  Commits changes

> git commit -m "Add ToDo and modify README"

# [master 7b679fa] Add ToDo and modify README

#  2 files changed, 2 insertions(+)

#  create mode 100644 ToDo


> git status                  

# On branch master

# nothing to commit, working directory clean




Example Git workflow
• Eva creates a README text file


• Adds file to STAGING AREA*


• Commit changes*


• Eva modifies README and adds a ToDo text file


• Adds both to STAGING AREA*


• Commit changes*


1.

2.

3.

4.

5.

6.

…But, how do we see the history of our project changes?



> git log

# commit 7b679fa747e8640918fcaad7e4c3f9c70c87b170

# Author: Barry Grant <bjgrant@umich.edu>

# Date:   Thu Jul 30 11:43:40 2015 -0400

#

#    Add ToDo and finished README

#

# commit 86768401610770ae32e2fd4faee07d1d5c68619c

# Author: Barry Grant <bjgrant@umich.edu>

# Date:   Thu Jul 30 11:26:40 2015 -0400

#

#    Create a README file

#

git log: Timeline history of 
snapshots (i.e. commits)



> git log

# commit 7b679fa747e8640918fcaad7e4c3f9c70c87b170

# Author: Barry Grant <bjgrant@umich.edu>

# Date:   Thu Jul 30 11:43:40 2015 -0400

#

#    Add ToDo and finished README

#

# commit 86768401610770ae32e2fd4faee07d1d5c68619c

# Author: Barry Grant <bjgrant@umich.edu>

# Date:   Thu Jul 30 11:26:40 2015 -0400

#

#    Create a README file

#

git log: Timeline history of 
snapshots (i.e. commits)

Past



Side-Note: Git history is akin

 to a graph

7b67…

8676…

HEAD
Nodes are commits labeled by their 

unique ‘commit ID’.


(This is a CHECKSUM of the commits 
author, time, commit msg, commit content 

and previous commit ID).


HEAD is a reference (or ‘pointer’) to the 
currently checked out commit (typically the 

most recent commit).

Time



Projects can have complicated 
graphs due to branching

7b67…

8676…

HEAD

Master

59d6…

Feature BugFix

1g9k…

39x2…

Branches allow you to work independently 
of other lines of development we will talk 

more about these later!



Key Points:

 


You explicitly and iteratively tell git what files to 
track (“git add”) and snapshot (“git commit”).


Git keeps an historical log “(git log”) of the 
content changes (and your comments on these 

changes) at each past commit.


It is good practice to regularly check the status 
of your working directory, staging arena repo 

(“git status“)



Break



> git status        # Get a status report of changes since last commit


> git add <filename>              # Tell Git which files to track/stage


> git commit -m ‘Your message’    # Take a content snapshot!

> git log                                         # Review your commit history 

> git diff <commit.ID>  <commit.ID> # Inspect content differences


> git checkout  <commit.ID>  # Navigate through the commit history

Summary of key Git commands:




Your 

Directory

‘Staging 

Area’

Local 

Repository

add

commit

checkout

diff

diff <commit.ID>

status

log



> git diff 8676 7b67

# diff --git a/README b/README

# index 73bc85a..67bd82c 100644

# --- a/README

# +++ b/README

# @@ -1 +1,2 @@

#  This is a first line of text.

# +This is a 2nd line of text.

# diff --git a/ToDo b/ToDo

# new file mode 100644

# index 0000000..14fbd56

# --- /dev/null

# +++ b/ToDo

# @@ -0,0 +1 @@

# +Learn git basics

git diff: Show changes 

between commits

7b67…

8676…



> git diff 7b67 8676

# diff --git a/README b/README

# index 67bd82c..73bc85a 100644

# --- a/README

# +++ b/README

# @@ -1,2 +1 @@

#  This is a first line of text.

# -This is a 2nd line of text.

# diff --git a/ToDo b/ToDo

# deleted file mode 100644

# index 14fbd56..0000000

# --- a/ToDo

# +++ /dev/null

# @@ 1 +0,0 @@

# -Learn git basics

git diff: Show changes 

between commits

7b67…

8676…



> git diff 8676                 ## Difference to current HEAD position!

# diff --git a/README b/README

# index 73bc85a..67bd82c 100644

# --- a/README

# +++ b/README

# @@ -1 +1,2 @@

#  This is a first line of text.

# +This is a 2nd line of text.

# diff --git a/ToDo b/ToDo

# new file mode 100644

# index 0000000..14fbd56

# --- /dev/null

# +++ b/ToDo

# @@ -0,0 +1 @@

# +Learn git basics

HEAD

git diff: Show changes 

between commits

7b67…

8676…



HEAD advances automatically with 
each new commit

HEAD 7b67…

8676…

To move HEAD (back or forward) 
on the Git graph (and retrieve the 
associated snapshot content) we 

can use the command:


> git checkout <commit.ID>




> more README

This is a first line of text.

This is a 2nd line of text.


> git log --oneline

# 7b679fa  Add ToDo and finished README

# 8676840  Create a README file


git checkout: Moves HEAD 


7b67…

8676…

HEAD



> more README

This is a first line of text.

This is a 2nd line of text.


> git log --oneline

# 7b679fa  Add ToDo and finished README

# 8676840  Create a README file


> git checkout 86768

# You are in 'detached HEAD' state…<cut>…

# HEAD is now at 8676840... Create a README file


> more README

This is a first line of text.


> git log --oneline

# 8676840  Create a README file

7b67…

8676…HEAD

git checkout: Moves HEAD 

(e.g. back in time)

Do it Yourself!



> git checkout master

# Previous HEAD position was 8676840... Create a README file

# Switched to branch 'master'

> git log --oneline

# 7b679fa Add ToDo and finished README

# 8676840 Create a README file


> more README

This is a first line of text.

This is a 2nd line of text.


7b67…

8676…

HEAD

git checkout: Moves HEAD 

(e.g. back to the future!)



Side-Note: There are two* main ways to 

use git checkout

• Checking out a commit makes the entire working 
directory match that commit. This can be used to 
view an old state of your project.


> git checkout <commit.ID>


• Checking out a specific file lets you see an old 
version of that particular file, leaving the rest of 
your working directory untouched.


> git checkout <commit.ID> <filename>



You can discard revisions 

with git revert

• The git revert command undoes a committed 
snapshot. 


• But, instead of removing the commit from the 
project history, it figures out how to undo the 
changes introduced by the commit and appends 
a new commit with the resulting content. 


> git revert <commit.ID>


• This prevents Git from losing history!



Removing untracked files 

with git clean

• The git clean command removes untracked files from 
your working directory. 


• Like an ordinary rm command, git clean is not 
undoable, so make sure you really want to delete the 
untracked files before you run it.


> git clean -n # dry run display of files to be ‘cleaned’


> git clean -f   # remove untracked files



GUIs
Tower (Mac only) 


GitHub_Desktop (Mac, Windows) 

SourceTree (Mac, Windows)


SmartGit (Linux)

RStudio

Demo Tower

https://git-scm.com/downloads/guis

https://git-scm.com/downloads/guis

