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Last class revisited...

» Write a function grade() to determine an overall
grade from a vector of student homework
assignment scores dropping the lowest single
assignment score.

# student 1
c(100, 100, 100, 100, 100, 100, 100, 90)

# student 2
c(100, NA, 90, 90, 90, 90, 97, 80)

# now grade all students in an example class
url <- "https://tinyurl.com/gradeinput"”

Barry\Grant ’
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function()

Last class revisited...

» Write a function grade() to determine an overall
grade from a vector of student homework
assignment scores dropping the lowest single
assignment score.

grade <- (x) {
X <- as.numeric(x)
X[ is.na(x)] =
mean(x[ -which.min(x) 1)

}




Last class revisited...

* Write a function grade() to determine an overall
grade from a vector of student homework
assignment scores dropping the lowest single
assignment score.

grade <- function(x) {
X <- as.numeric(x)
X[ is.na(x)] =
mean(x[ -which.min(x) 1)

}

Do this now...

» Write a function grade2() to determine an overall
grade from a vector of student homework
assignment scores OPTIONALLY dropping the
lowest single assignment score.

grade <- function(x) {
X <- as.numeric(x)
X[ is.na(x)] =
mean(x[ -which.min(x) 1)

}

Last class revisited...

* Write a function grade() to determine an overall
grade from a vector of student homework
assignment scores dropping the lowest single
assignment score.

grade <- function(x) { \
X <- as.numeric(x)
X[ is.na(x)] = 0
mean(x[ -which.min(x) 1)

}

Last class revisited...

grade2 <- function(x, drop.lowest=TRUE) {
X <- as.numeric(x)
X[ is.na(x)] = 0
if (drop.lowest) {
mean(x[ -which.min(x) 1])
} else {
mean(x)

}

}




And some function homework....

Complete Q6. In last days lab supplement

Suggested steps for writing
your functions

Start with a simple problem and get a working snippet of code
Rewrite to use temporary variables (e.g. x, y, df, m etc.)
Rewrite for clarity and to reduce calculation duplication

Turn into an initial function with clear useful names

Test on small well defined input and (subsets of) real input
Report on potential problem by failing early and loudly!

Refine and polish

library(bio3d)

sl <- read.pdb("4AKE") #
s2 <- read.pdb("1lAKE") #
s3 <- read.pdb("1lE4Y") #

sl.chainA <- trim.pdb(sl,
s2.chainA <- trim.pdb(s2,
s3.chainA <- trim.pdb(sl,

sl.b <- sl.chainA$atom$b
s2.b <- s2.chainASatomS$b
s3.b <- s3.chainAS$atom$b

kinase
kinase
kinase

chain=
chain=
chain=

plotb3(sl.b, sse=sl.chainA, typ=
plotb3(s2.b, sse=s2.chainA, typ="1",
plotb3(s3.b, sse=s3.chainA, typ="1",

with drug
no drug
with drug
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elety="CA")
elety="CA")
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"Bfactor")
"Bfactor")
"Bfactor")




What is Git? What is Git?

(1) An unpleasant or contemptible f (1) An unpleasant or contemptible
person. Often incompetent, person. Often incompetent,
annoying, senile, elderly or childish : annoying, senile, elderly or childish
in character. in character.

(2) A modern distributed version ° (2) A modern distributed version °
control system with an emphasis 0 glt control system with an emphasis 0 glt

on speed and data integrity. on speed and data integrity.

Version Control

Version control systems (VCS) record changes to

afile or set of files over time so that you can O :lg////-{
recall specific versions later. AN / I o
o o E hasa repository each ._@ a»
access S ‘//v =
/ code repository
= @
Free/open-source CVS (1986, 1990 in C) - CVSNT (1998) - QVCS Enterprise (1998) + Subversion (2000) g \ g
Software Change Manager (1970s) - Panvalet (1970s) - Endevor (1980s) - Dimensions CM D a» E
e (1980s) - DSEE (1984) - Synergy (1990) - ClearCase (1992) - CMVC (1994) - Visual SourceSafe g
Proprietary  (1994) - Perforce (1995) - StarTeam (1995) - Integrity (2001)  Surround SCM (2002) « 1 i i
AccuRev SCM (2002) - SourceAnywhere (2003) - Vault (2003) - Team Foundation Server (2005) Cllent-server approach Distributed approaCh
Team Concert (2008)
GNU arch (2001) - Darcs (2002) - DCVS (2002)  ArX (2003) - Monotone (2003) + SVK (2003)
Free/open-source Codeville (2005) - Bazaar (2005) - Git (2005) - Mercurial (2005) - Fossil (2007) - Veracity (2010)
Distributed ‘ : * Merou : *ven H H H
Proprietary TeamWare (1990s?) - Code Co-op (1997) - BitKeeper (1998) - Plastic SCM (2006) D I Strl b Uted version Contro' SyStemS ( DCVS) al | ows

multiple people to work on a given project without
requiring them to share a common network.



THE #1 PROGRAMMER EXCUSE
FOR LEGITIMATELY SLACKING OFF:

“The Subversion server’s down”

http://tinyurl.com/distributed-advantages

Where did Git come from?

Written initially by Linus Torvalds to
support Linux kernel and OS
development.

Meant to be distributed, fast and more
natural.

Capable of handling large projects.

Now the most popular free VCS!

Git is now the most popular free VCS!

THE #1 PROGRAMMER EXCUSE
FOR LEGITIMATELY SLACKING OFF:

“The Subversion server’s down” Git offers:
* Speed
* Backups
* Off-line access
» Small footprint
* Simplicity*
* Social coding

http://tinyurl.com/distributed-advantages




Why use Git?

Q. Would you write your lab boolk
pencil, then erase and overwrite it
every cio\j with new conbtent?

Version control is the lab notebook of the digital
world: it's what professionals use to keep track of
what they’ve done and to collaborate with others.

Q. Would you write your lab boolk
pencil, then erase and overwrite it
every cio\j with new conbtent?

Why use Git?

Provides ‘snapshots’ of your project during development and
provides a full record of project history.

Allows you to easily reproduce and rollback to past versions of
analysis and compare differences. (N.B. Helps fix software
regression bugs!)

Keeps track of changes to code you use from others such as
fixed bugs & new features

Provides a mechanism for sharing, updating and collaborating
(like a social network)

Helps keep your work and software organized and available




Note: You hopefully already have git installed!
To check open the “Terminal” tab in RStudio and type:

@which git
@ git --version

Obtaining Git

Obtaining Git

Note: You might already have git installed Note: You might already have git installed :
To check open the “Terminal” tab in RStudio and type: | To check open the “Terminal” tab in RStudio and type: |
: @which git :

@which git
@git --version

@git --version
Obtaining Git Obtaining Git
Mac Only (if you have problems)

I inal kd b
SONSOIE B R Markdown Jobs Windows Only (if you have problems)
Terminal 1 ~ | class06 " . o . )
zico: > which git If the “which git com.mand did not work, try: If the “which git” command did not work, you
where git may need to install select developer tools.

/usr/bin/git
zico: > git --version If this works see next slide. If not then you In vour Terminal tvpe:
need to install GitBash, instructions here: ’
xcode-select --install

git version 2.30.1 (Apple Git-130)
zico: > Class Computer Setup Page




On a PC Only!

Options

Shell

New terminals open with: Git Bash

Connection

e terminal when shell exits
R Marke

-4

2) Using th o terminal

“& publishing

W erminal

Configuring Git

Go to: RStudio > Tools > Global Options > Terminal

Make sure
Git Bash is
selected!

Note: You might already have git installed :
To check open the “Terminal” tab in RStudio and type: |

@which git
@ git --version

Installing Git

Windows (if you have problems)
Follow the GitBash instructions here:

Class Computer Setup Page

Mac (if you have problems)
In the Terminal instal select developer tools

xcode-select --install

Configuring Git
(RStudio Terminal Tab)
(...or RStudio > Tools > Shell)

# First tell Git who you are
> git config --global user.name “Barry Grant”
> git config --global user.email “bjgrant@ucsd.edu”




Configuring RStudio

On a PC!

Go to: RStudio > Tools > Global Options > Git/SVN

1 Make sure this is ticked!
2 This is the PATH for PC!

For Mac & Linux
(PC on next slide)

Go to: RStudio > Tools > Global Options > Git/SVN

1 Make sure this is ticked!
2 Make sure this is correct!

Check in your RStudio “Teiminal” tab:
Console = Terminal R Markdown
Terminal ¥~ | another
blitz: > which git
/usr/local/bin/git
blitz: >

Restart RStudio!




Using Git

1. Initiate a Git repository,
2. EAit content (Le. change some files).
3. Store a ‘snapshot’ of the current file statex

Create a new Test : _ .
RStudio project Using Git in RStudio

1 New option to create

a Git repository. . 2 New Git tab... . Initiate a git repository for an RStudio Project

Environment  History  Connections GED .
) ] . Do your work and edit content as normal
Staged Status Path
[ ] B B .itignor . . . . T . »
8 EmE r . Periodically add important files to git “Staging Area

. Commit changes to your “git repository”

Rinse and repeat....
Check if new Git options appear in RStudio?




GitHub & Bitbucket

GitHub and Bitbucket are two popular hosting services for
Git repositories. These services allow you to share your
projects and collaborate with others using both ‘public’ and
‘private’ repositories*.

https://bitbucket.org ..

B smn
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What is the big deal? First sign up for a GitHub account

https:/github.com

* At the simplest level GitHub and Bitbucket offer backup of

your projects history and a centralized mechanism for Py e e e
sharing with others by putting your Git repo online.

* GitHub in particular is often referred to as the “nerds

FaceBook and LinkedIn combined”. Build software
» Attheir core both services offer a new paradigm for open better, together

collaborative project development, particularly for software. Powerful collaboration, code review, and code management for
open source and private projects. Public projects are always free.

* In essence they allow anybody to contribute to any public
project and get acknowledgment.

Pick the FREE plan! Your GitHub homepage

Check your email for verification request

Pull requests _Issu

Welcome to GitHub

You've taken your first step into a larger world, @biobootStudent
supz
10 e sourpien

Ghoose your personal plan




Connecting RStudio to
GitHub

Create a Personal Access Token (PAT) on GitHub

See section 4 of lab worksheet

Name your repo
bimm143

Skip the hello-world tutorial

https://guides.qgithub.com/activities/hello-world

Copy the “Clone” HTTPS link

bggn213




RStudio > New Project > Version Control RStudio > New Project > Version Control

New Project New Project

Create Project Back Clone Git Repository

Repository URL:

New Directory - " . .
https: ithub.com/bioboot,
Start a project in a brand new working directory ps://github.com/bi /bimm143.git

Project directory name:
bimm143_github
Create project as subdirectory of:

Existing Directory
~/Desktop/courses/ bimm143 Browse...

Associate a project with an existing working directory

Version Control
Checkout a project from a version control repository

v®pen in new session Create Project Cancel

Demo of editing, adding Demo of editing, adding
committing and pushing committing and pushing

Check if new Git tab Check if new Git tab
Appears in RStudio? Appears in RStudio?

Now experiment editing the
Environment  History  Connections GE m Environment  History  Connections GE m README.md file in RStudio
B Diff Commit © |- Now experiment editing the B Diff Commit © |- and adding, committing and
Staged Status Path README.md file in RStudio Staged Status Path pushing changes to GitHub
a B B gitignore and adding, committing and [ ] B B gitignore via this tab
[ ] B B test.Rproj pushing changes to GitHub [ ] B B test.Rproj
via this tab
When you are ready copy your
different class directories/projects
to this new GitHub tracked folder




Side-note: How to edit online

Specifically lets add some Markdown content

tudent / demo1_github

demof_github / README

Learning Resources

Set up Git. If you will be using Git mostly or entirely via
GltHub look at these how- tos

Pro Git. A complete, book-length guide and reference to Git,

by Scott Chacon and Ben Straub
< http://git-scm.com/

StackOverflow. Excellent programmlng and developer Q&A.

< http://stackoverf

Summary

* Git is a popular ‘distributed’ version control
system that is lightweight and free

* GitHub and BitBucket are popular hosting
services for git repositories that have changed the
way people contribute to open source projects

* Introduced basic git and GitHub usage within
RStudio and encouraged you to adopt these ‘best
practices’ for your future projects.

Learning git can be painful!

However in practice it is not nearly as crazy-making as
the alternatives:

Documents as email attachments

Hair-raising ZIP archives containing file salad
Am | working with the most recent data”?
Archaelogical “digs” on old email threads and

uncertainty about how/if certain changes have been
made or issues solved




Finally Please remember that GitHub

and BitBucket are PUBLIC and that

you should cultivate your professional
and scholarly profile with intention!
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Using Command Line Git

1. Initiate a Git repos&or
2. EAit content (Le. change some files).
3. Store a ‘snapshot’ of the current file state.x




Initiate a Git repository

Side-Note: The .qgit/ directory
Git created a ‘hidden’ .git/ directory inside your
current working directory.

You can use the ‘Is -a’ command to list (i.e. see)
this directory and its contents.

This is where Git stores all its goodies - this is
Git!

You should not need to edit the contents of the .git
directory for now but do feel free to poke around.

Initiate a Git repository

> cd ~/Desktop

> mkdir git_class # Make a new directory

> cd git_class # Change to this directory
> git init # Our first Git commana!
> s -a # what happened?

Important Git commands

’ > git status # report on content changes

[> git add <filename>  # stage/track a file
> git commit -m “message” # snapshot




Important Git commands

git status # report on content changes

git add <filename>  # stage/track a file
git commit -m “message” # snapshot

[
f
f
1
|
i
1}
i
|
L

You will use these three commands again and again in your Git workflow!

Example Git workflow

Eva creates a README text file
(this starts as untracked)

Adds file to STAGING AREA*
(tracked and ready to take a snapshot)

Commit changes*
(records snapshot of staged files!)

Git TRACKS your directory content

» To get a report of changes (since last commit) use:
> git status

¢ You tell Git which files to track with:
> git add <filename>

This adds files to a so called STAGING AREA
(akin to a “shopping cart” before purchasing).

* You tell Git when to take an historical SNAPSHOT of
your staged files (i.e. record their current state) with:

> git commit -m ‘Your message about changes’

Example Git workflow

Eva creates a README text file
Adds file to STAGING AREA*

Commit changes*

N

n Adds both to STAGING AREA*

Commit changes*

Eva modifies README and adds a ToDo text file
]
I




Eva creates a README file

> # cd ~/Desktop/git_class
> # git init

> echo "This is a first line of text." > README
> git status # Report on changes

z On branch Ea;s‘@

# Initial commit
#
IUmracked files: |
#%use@ﬁ#add—ﬂdwlw.. " to include in what will be committed)

#
#

# nothing added to commit but untracked files present (use "git add" to track)

3. Commit changes

> git commit -m “Create a README file” # Take snapshot
# [master (root-commit) 8676840] Create a README file

# 1 file changed, 1 insertion(+)

# create mode 100644 README

> git status # Report on changes

# On branch master
# nothing to commit, working directory clean

2. Adds to ‘staging area’

> gitadd README  # Add README file to staging area
> git status # Report on changes

# On branch master

#

# Initial commit

#xChanges to be committed: I

L‘(Ugi,r“gn'mr‘cac‘rmd*zfrreﬁ ' to unstage)

ew file:  README

4. Eva modifies README file
and adds a ToDo file

> echo "This is a 2nd line of text." >> README
> echo "Learn git basics" >> ToDo

> git status # Report on changes

# On branch master
#
# Changes not staged for commit
# (use 'git add <file>..." to update what will be committed)
(use "git checkout -- <file>..." to discard changes in working directory)

modified:

#

#

#

#

# Untracked files:
# (use 'git add <file>..." to include in what will be committed)
#
#
#
#

no changes added to commit (use "git add" and/or "git commit -a")




5. Adds both files to ‘staging area’ 6. Commits changes

> gitadd README ToDo # Add both files to ‘staging area’ > git commit -m "Add ToDo and modify README"

> git status # Report on changes # [master 7b679fa] Add ToDo and modify README
# On branch master # 2files changed, 2 insertions(+)
# Changes to be committed: # create mode 100644 ToDo

# (use "git reset HEAD <file>..." to unstage)

> git status

#
# modified: README # On branch master

# new file: ToDo # nothing to commit, working directory clean
#

git log: Timeline history of

Example Git workflow snapshots (i.e. commits)

1. Eva creates a README text file > git log
N # commit 7b679fa747e8640918fcaad7e4c3foc70c87b170
&} Adds file to STAGING AREA* # Author: Barry Grant <bjgrant@umich.edu>
# Date: Thu Jul 30 11:43:40 2015 -0400
Commit changes* #
9 # Add ToDo and finished README
#
# commit 86768401610770ae32e2fd4face07d1d5¢c68619¢
# Author: Barry Grant <bjgrant@umich.edu>
4. Eva modifies README and adds a ToDo text file #Date:  Thu Jul 30 11:26:40 2015 -0400
N # _
Adds both to STAGING AREA* # Create a README file
#

Commit changes*

...But, how do we see the history of our project changes?




git log: Timeline history of
snapshots (i.e. commits)

> git log

# commit 7b679fa747e8640918fcaad7e4c3foc70c87b170
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:43:40 2015 -0400

#

# Add ToDo and finished README

#

# commit 86768401610770ae32e2fd4face07d1d5¢c68619¢
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:26:40 2015 -0400

#

# Create a README file

#

Projects can have complicated
graphs due to branching

Master Feature

5906...
1g9K. .

Branches allow you to work independently
of other lines of development we will talk
more about these later!

Side-Note: Git history is akin
to a graph

Nodes are commits labeled by their
m 7 unique ‘commit ID".
(This is a CHECKSUM of the commits
author, time, commit msg, commit content
and previous commit ID).

?

8‘3' v HEAD is a reference (or ‘pointer’) to the
currently checked out commit (typically the
most recent commit).




Summary of key Git commands:

| > git status # Get a status report of changes since last commit

> git add <filename> # Tell Git which files to track/stage

> git commit -m ‘Your message’ # Take a content snapshot!

> git log # Review your commit history

> git diff <commit.ID> <commit.ID> # Inspect content differences

> git checkout <commit.ID> # Navigate through the commit history

git diff: Show changes
Area’ Repository between commits

‘Staging Local

O0— > git diff 8676 7b67

# diff --git a/README b/README

# index 73bc85a..67bd82c 100644
# --- a/README

# +++ b/README
#Q@@-1+12@@

# This is a first line of text.

# +This is a 2nd line of text

# diff --git a/ToDo b/ToDo
# new file mode 100644

# index 0000000..14fbd56
# --- /dev/null

# +++ b/ToDo

#@@-0,0 +1 @@

# +Learn git basics




git diff: Show changes
between commits

> git diff 7b67 8676

# diff --git a/README b/README

# index 67bd82c..73bc85a 100644
# --- a/README

# +++ b/README

#@@-12+1 @@

# This is a first line of text.

#

# diff --git a/ToDo b/ToDo

# deleted file mode 100644
# index 14fbd56..0000000
# --- a/ToDo

# +++ /dev/null

#@@ 1 +0,0 @@

#

HEAD advances automatically with
each new commit

m 7.7' i To move HEAD (back or forward)

on the Git graph (and retrieve the
associated snapshot content) we
can use the command:

> git checkout <commit.ID>

git diff: Show changes
between commits

> git diff 8676 ## Difference to current HEAD position!
# diff --git a/README b/README

# index 73bc85a..67bd82c 100644 ?

# --- a/README

# +++ b/README m 7.7_ N
#@@-1+12@@

# This is a first line of text.
# +This is a 2nd line of text

# diff --git a/ToDo b/ToDo
# new file mode 100644
# index 0000000..14fbd56 8.6 ..
# --- /dev/null

# +++ b/ToDo
#@@-0,0+1 @@
# +Learn git basics

git checkout: Moves HEAD

> more README
This is a first line of text.
This is a 2nd line of text.

> git log --oneline m 7.7
#7b679fa Add ToDo and finished README e

# 8676840 Create a README file




git checkout: Moves HEAD git checkout: Moves HEAD
(e.g. back in time) (e.g. back to the future!)

> more README > git checkout master
This is a first line of text. # Previous HEAD position was 8676840... Create a README file
This is a 2nd line of text. # Switched to branch 'master’

> git log --oneline > git log --oneline m 7.7
# 7b679fa Add ToDo and finished README T # 7b679fa Add ToDo and finished README e
# 8676840 Create a README file # 8676840 Create a README file

= git checkout 86768 > more README
# You are in 'detached HEAD' state...<cut>... This is a first line of text.
# HEAD is now at 8676840... Create a README file This is a 2nd line of text.

> more README 8.6 =

This is a first line of text.

> git log --oneline
# 8676840 Create a README file

Side-Note: There are two* main ways to You can discard revisions
use git checkout with git revert

* Checking out a commit makes the entire working * The git revert command undoes a committed

directory match that commit. This can be used to snapshot.

view an old state of your project.

« But, instead of removing the commit from the
> git checkout <commit.ID> project history, it figures out how to undo the
changes introduced by the commit and appends

* Checking out a specific file lets you see an old a new commit with the resulting content.

version of that particular file, leaving the rest of

your working directory untouched. > git revert <commit.ID>

> git checkout <commit.ID> <filename>  This prevents Git from losing history!




Removing untracked files
with git clean

* The git clean command removes untracked files from
your working directory.

 Like an ordinary rm command, git clean is not G U IS

undoable, so make sure you really want to delete the
untracked files before you run it. Tower (Mac only)

GitHub_Desktop (Mac, Windows)
> git clean -n # dry run display of files to be ‘cleaned’ SourceTree (Mac, Windows)

SmartGit (Linux)
> git clean -f # remove untracked files RStudio

https://qgit-scm.com/downloads/quis




