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How do we make informative 
and compelling figures?





Currently the premier plotting 
library on the planet!
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Common aesthetics include

Modified from: Wilke (2019)
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Data Visualization with ggplot2 : : CHEAT SHEET 
ggplot2 is based on the grammar of graphics, the idea 
that you can build every graph from the same 
components: a data set, a coordinate system, 
and geoms—visual marks that represent data points.

Basics
GRAPHICAL PRIMITIVES

a + geom_blank() 
(Useful for expanding limits) 

b + geom_curve(aes(yend = lat + 1, 
xend=long+1),curvature=1) - x, xend, y, yend, 
alpha, angle, color, curvature, linetype, size 

a + geom_path(lineend="butt", linejoin="round", 
linemitre=1) 
x, y, alpha, color, group, linetype, size 

a + geom_polygon(aes(group = group)) 
x, y, alpha, color, fill, group, linetype, size 

b + geom_rect(aes(xmin = long, ymin=lat, xmax= 
long + 1, ymax = lat + 1)) - xmax, xmin, ymax, 
ymin, alpha, color, fill, linetype, size 

a + geom_ribbon(aes(ymin=unemploy - 900, 
ymax=unemploy + 900)) - x, ymax, ymin, 
alpha, color, fill, group, linetype, size

+ =

To display values, map variables in the data to visual 
properties of the geom (aesthetics) like size, color, and x 
and y locations.

+ =

data geom 
x = F · y = A

coordinate 
system

plot

data geom 
x = F · y = A 
color = F 
size = A

coordinate 
system

plot

Complete the template below to build a graph.
required

ggplot(data = mpg, aes(x = cty, y = hwy)) Begins a plot 
that you finish by adding layers to. Add one geom 
function per layer.      
  

qplot(x = cty, y = hwy, data = mpg, geom = “point") 
Creates a complete plot with given data, geom, and 
mappings. Supplies many useful defaults.     

last_plot() Returns the last plot  

ggsave("plot.png", width = 5, height = 5) Saves last plot 
as 5’ x 5’ file named "plot.png" in working directory. 
Matches file type to file extension.

F M A

F M A

aesthetic mappings data geom

LINE SEGMENTS

b + geom_abline(aes(intercept=0, slope=1)) 
b + geom_hline(aes(yintercept = lat)) 
b + geom_vline(aes(xintercept = long))

common aesthetics: x, y, alpha, color, linetype, size

b + geom_segment(aes(yend=lat+1, xend=long+1)) 
b + geom_spoke(aes(angle = 1:1155, radius = 1))

a <- ggplot(economics, aes(date, unemploy)) 
b <- ggplot(seals, aes(x = long, y = lat))

ONE VARIABLE    continuous
c <- ggplot(mpg, aes(hwy)); c2 <- ggplot(mpg)

c + geom_area(stat = "bin") 
x, y, alpha, color, fill,  linetype, size 

c + geom_density(kernel = "gaussian") 
x, y, alpha, color, fill, group, linetype, size, weight 

c + geom_dotplot()  
x, y, alpha, color, fill 

c + geom_freqpoly() x, y, alpha, color, group, 
linetype, size 

c + geom_histogram(binwidth = 5) x, y, alpha, 
color, fill, linetype, size, weight 

c2 + geom_qq(aes(sample = hwy)) x, y, alpha, 
color, fill, linetype, size, weight

discrete
d <- ggplot(mpg, aes(fl))

d + geom_bar()  
x, alpha, color, fill, linetype, size, weight

e + geom_label(aes(label = cty), nudge_x = 1, 
nudge_y = 1, check_overlap = TRUE) x, y, label, 
alpha, angle, color, family, fontface, hjust, 
lineheight, size, vjust 

e + geom_jitter(height = 2, width = 2)  
x, y, alpha, color, fill, shape, size 

e + geom_point(), x, y, alpha, color, fill, shape, 
size, stroke 

e + geom_quantile(), x, y, alpha, color, group, 
linetype, size, weight 

e + geom_rug(sides = "bl"), x, y, alpha, color, 
linetype, size 

e + geom_smooth(method = lm), x, y, alpha, 
color, fill, group, linetype, size, weight 

e + geom_text(aes(label = cty), nudge_x = 1, 
nudge_y = 1, check_overlap = TRUE), x, y, label, 
alpha, angle, color, family, fontface, hjust, 
lineheight, size, vjust

discrete x , continuous y 
f <- ggplot(mpg, aes(class, hwy))

f + geom_col(), x, y, alpha, color, fill, group, 
linetype, size 

f + geom_boxplot(), x, y, lower, middle, upper, 
ymax, ymin, alpha, color, fill, group, linetype, 
shape, size, weight 

f + geom_dotplot(binaxis = "y", stackdir = 
"center"), x, y, alpha, color, fill, group 

f + geom_violin(scale = "area"), x, y, alpha, color, 
fill, group, linetype, size, weight

discrete x , discrete y 
g <- ggplot(diamonds, aes(cut, color))

g + geom_count(), x, y, alpha, color, fill, shape, 
size, stroke

THREE VARIABLES 
seals$z <- with(seals, sqrt(delta_long^2 + delta_lat^2)); l <- ggplot(seals, aes(long, lat))

l + geom_contour(aes(z = z)) 
x, y, z, alpha, colour, group, linetype,  
size, weight

l + geom_raster(aes(fill = z), hjust=0.5, vjust=0.5, 
interpolate=FALSE) 
x, y, alpha, fill 

l + geom_tile(aes(fill = z)), x, y, alpha, color, fill, 
linetype, size, width

h + geom_bin2d(binwidth = c(0.25, 500)) 
x, y, alpha, color, fill, linetype, size, weight 

h + geom_density2d() 
x, y, alpha, colour, group, linetype, size 

h + geom_hex() 
x, y, alpha, colour, fill, size 

 

i + geom_area() 
x, y, alpha, color, fill, linetype, size 

i + geom_line() 
x, y, alpha, color, group, linetype, size 

i + geom_step(direction = "hv") 
x, y, alpha, color, group, linetype, size 
 
 
 

j + geom_crossbar(fatten = 2) 
x, y, ymax, ymin, alpha, color, fill, group, linetype, 
size 

j + geom_errorbar(), x, ymax, ymin, alpha, color, 
group, linetype, size, width (also 
geom_errorbarh()) 

j + geom_linerange() 
x, ymin, ymax, alpha, color, group, linetype, size 

j + geom_pointrange() 
x, y, ymin, ymax, alpha, color, fill, group, linetype, 
shape, size

continuous function 
i <- ggplot(economics, aes(date, unemploy))

visualizing error 
df <- data.frame(grp = c("A", "B"), fit = 4:5, se = 1:2) 
j <- ggplot(df, aes(grp, fit, ymin = fit-se, ymax = fit+se))

maps 
data <- data.frame(murder = USArrests$Murder, 
state = tolower(rownames(USArrests))) 
map <- map_data("state") 
k <- ggplot(data, aes(fill = murder))

k + geom_map(aes(map_id = state), map = map) 
+ expand_limits(x = map$long, y = map$lat), 
map_id, alpha, color, fill, linetype, size

Not  
required, 
sensible 
defaults 
supplied

Geoms Use a geom function to represent data points, use the geom’s aesthetic properties to represent variables.  
Each function returns a layer.

TWO VARIABLES 
continuous x , continuous y 
e <- ggplot(mpg, aes(cty, hwy))

 
continuous bivariate distribution 
h <- ggplot(diamonds, aes(carat, price))

RStudio® is a trademark of RStudio, Inc.  •  CC BY SA  RStudio •  info@rstudio.com  •  844-448-1212 • rstudio.com •  Learn more at  http://ggplot2.tidyverse.org •  ggplot2  3.1.0  •  Updated: 2018-12

ggplot (data =  <DATA> ) +  
  <GEOM_FUNCTION> (mapping = aes( <MAPPINGS> ),  
  stat = <STAT> , position = <POSITION> ) +      
  <COORDINATE_FUNCTION> + 
  <FACET_FUNCTION>  + 
  <SCALE_FUNCTION>  + 
  <THEME_FUNCTION>

Learn more about core 
geom_FUNCTIONS()

There are > 40 core "geom" functions.

See cheat-sheet link on class website!



In addition to your PDF lab report answer the inbuilt questions
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Console 
The “R Brain” 



RStudio > File > New Project > New Directory
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RStudio > File > New Project > New Directory



RStudio > File > New Project > New Directory

Make a new class Folder (a.k.a. Directory) 
for storing your lab work




RStudio > File > New Project > New Directory

We will use a new RStudio “Project” within 
this folder (i.e. a subdirectory) for each class




File > New File > Quarto Document



File > New File > Quarto Document

N.B. we will use this to save our work and make a lab report











Follow Along!

demo



Currently the premier plotting 
library on the planet!

Summary!



• Summary:  ggplot takes an input data.frame, a mapping of columns to 
aesthetics and one or more geom layers (e.g. geom_point(), geom_line(), ...)

ggplot(data=mpg) +
  aes(x=displ, y=hwy) +
  geom_point()

data + aesthetics + geometrys

Data

Aesthetics

Geometries

+
+
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ggplot(data=mpg) +
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  geom_point()

• Summary:  ggplot takes an input data.frame, a mapping of columns to 
aesthetics and one or more geom layers (e.g. geom_point(), geom_line(), ...)
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• We can keep building more complicated plots by adding more layers

ggplot(data=mpg) +
  aes(x=displ, y=hwy) +
  geom_point()

data + aesthetics + geometrys



• We can keep building more complicated plots by adding more layers


• For example lets add another geom, in this case a smooth line fitted to 
the data...

ggplot(data=mpg) +
  aes(x=displ, y=hwy) +
  geom_point() +
  geom_smooth()

data + aesthetics + geometrys



• We can also add other customizations like themes...

ggplot(data=mpg) +
  aes(x=displ, y=hwy) +
  geom_point() +
  geom_smooth() +
  theme_bw()

data + aesthetics + geometrys



• And various custom annotation labels...

ggplot(data=mpg) +
  aes(x=displ, y=hwy) +
  geom_point() +
  geom_smooth() +
  theme_bw()

ggplot(data=mpg) +
 aes(x=displ, y=hwy) +
 geom_point() +
 geom_smooth() +
 theme_bw()+ 
  labs(title="My Main Title", 
       subtitle = "subtitle", 
       caption ="My Caption", 
       x="Displacement (L)", 
       y= "MPG (Higway)")

data + aesthetics + geometrys



ggplot(data=mpg) +
  aes(x=displ, y=hwy, color=class,
      shape=factor(cyl)) + 
  geom_point()



ggplot(data=mpg) +
  aes(x=displ, y=hwy, color=class) + 
  geom_point() +
  facet_wrap(~cyl)



Data Visualization with ggplot2 : : CHEAT SHEET 
ggplot2 is based on the grammar of graphics, the idea 
that you can build every graph from the same 
components: a data set, a coordinate system, 
and geoms—visual marks that represent data points.

Basics
GRAPHICAL PRIMITIVES

a + geom_blank() 
(Useful for expanding limits) 

b + geom_curve(aes(yend = lat + 1, 
xend=long+1),curvature=1) - x, xend, y, yend, 
alpha, angle, color, curvature, linetype, size 

a + geom_path(lineend="butt", linejoin="round", 
linemitre=1) 
x, y, alpha, color, group, linetype, size 

a + geom_polygon(aes(group = group)) 
x, y, alpha, color, fill, group, linetype, size 

b + geom_rect(aes(xmin = long, ymin=lat, xmax= 
long + 1, ymax = lat + 1)) - xmax, xmin, ymax, 
ymin, alpha, color, fill, linetype, size 

a + geom_ribbon(aes(ymin=unemploy - 900, 
ymax=unemploy + 900)) - x, ymax, ymin, 
alpha, color, fill, group, linetype, size

+ =

To display values, map variables in the data to visual 
properties of the geom (aesthetics) like size, color, and x 
and y locations.

+ =

data geom 
x = F · y = A

coordinate 
system

plot

data geom 
x = F · y = A 
color = F 
size = A

coordinate 
system

plot

Complete the template below to build a graph.
required

ggplot(data = mpg, aes(x = cty, y = hwy)) Begins a plot 
that you finish by adding layers to. Add one geom 
function per layer.      
  

qplot(x = cty, y = hwy, data = mpg, geom = “point") 
Creates a complete plot with given data, geom, and 
mappings. Supplies many useful defaults.     

last_plot() Returns the last plot  

ggsave("plot.png", width = 5, height = 5) Saves last plot 
as 5’ x 5’ file named "plot.png" in working directory. 
Matches file type to file extension.

F M A

F M A

aesthetic mappings data geom

LINE SEGMENTS

b + geom_abline(aes(intercept=0, slope=1)) 
b + geom_hline(aes(yintercept = lat)) 
b + geom_vline(aes(xintercept = long))

common aesthetics: x, y, alpha, color, linetype, size

b + geom_segment(aes(yend=lat+1, xend=long+1)) 
b + geom_spoke(aes(angle = 1:1155, radius = 1))

a <- ggplot(economics, aes(date, unemploy)) 
b <- ggplot(seals, aes(x = long, y = lat))

ONE VARIABLE    continuous
c <- ggplot(mpg, aes(hwy)); c2 <- ggplot(mpg)

c + geom_area(stat = "bin") 
x, y, alpha, color, fill,  linetype, size 

c + geom_density(kernel = "gaussian") 
x, y, alpha, color, fill, group, linetype, size, weight 

c + geom_dotplot()  
x, y, alpha, color, fill 

c + geom_freqpoly() x, y, alpha, color, group, 
linetype, size 

c + geom_histogram(binwidth = 5) x, y, alpha, 
color, fill, linetype, size, weight 

c2 + geom_qq(aes(sample = hwy)) x, y, alpha, 
color, fill, linetype, size, weight

discrete
d <- ggplot(mpg, aes(fl))

d + geom_bar()  
x, alpha, color, fill, linetype, size, weight

e + geom_label(aes(label = cty), nudge_x = 1, 
nudge_y = 1, check_overlap = TRUE) x, y, label, 
alpha, angle, color, family, fontface, hjust, 
lineheight, size, vjust 

e + geom_jitter(height = 2, width = 2)  
x, y, alpha, color, fill, shape, size 

e + geom_point(), x, y, alpha, color, fill, shape, 
size, stroke 

e + geom_quantile(), x, y, alpha, color, group, 
linetype, size, weight 

e + geom_rug(sides = "bl"), x, y, alpha, color, 
linetype, size 

e + geom_smooth(method = lm), x, y, alpha, 
color, fill, group, linetype, size, weight 

e + geom_text(aes(label = cty), nudge_x = 1, 
nudge_y = 1, check_overlap = TRUE), x, y, label, 
alpha, angle, color, family, fontface, hjust, 
lineheight, size, vjust

discrete x , continuous y 
f <- ggplot(mpg, aes(class, hwy))

f + geom_col(), x, y, alpha, color, fill, group, 
linetype, size 

f + geom_boxplot(), x, y, lower, middle, upper, 
ymax, ymin, alpha, color, fill, group, linetype, 
shape, size, weight 

f + geom_dotplot(binaxis = "y", stackdir = 
"center"), x, y, alpha, color, fill, group 

f + geom_violin(scale = "area"), x, y, alpha, color, 
fill, group, linetype, size, weight

discrete x , discrete y 
g <- ggplot(diamonds, aes(cut, color))

g + geom_count(), x, y, alpha, color, fill, shape, 
size, stroke

THREE VARIABLES 
seals$z <- with(seals, sqrt(delta_long^2 + delta_lat^2)); l <- ggplot(seals, aes(long, lat))

l + geom_contour(aes(z = z)) 
x, y, z, alpha, colour, group, linetype,  
size, weight

l + geom_raster(aes(fill = z), hjust=0.5, vjust=0.5, 
interpolate=FALSE) 
x, y, alpha, fill 

l + geom_tile(aes(fill = z)), x, y, alpha, color, fill, 
linetype, size, width

h + geom_bin2d(binwidth = c(0.25, 500)) 
x, y, alpha, color, fill, linetype, size, weight 

h + geom_density2d() 
x, y, alpha, colour, group, linetype, size 

h + geom_hex() 
x, y, alpha, colour, fill, size 

 

i + geom_area() 
x, y, alpha, color, fill, linetype, size 

i + geom_line() 
x, y, alpha, color, group, linetype, size 

i + geom_step(direction = "hv") 
x, y, alpha, color, group, linetype, size 
 
 
 

j + geom_crossbar(fatten = 2) 
x, y, ymax, ymin, alpha, color, fill, group, linetype, 
size 

j + geom_errorbar(), x, ymax, ymin, alpha, color, 
group, linetype, size, width (also 
geom_errorbarh()) 

j + geom_linerange() 
x, ymin, ymax, alpha, color, group, linetype, size 

j + geom_pointrange() 
x, y, ymin, ymax, alpha, color, fill, group, linetype, 
shape, size

continuous function 
i <- ggplot(economics, aes(date, unemploy))

visualizing error 
df <- data.frame(grp = c("A", "B"), fit = 4:5, se = 1:2) 
j <- ggplot(df, aes(grp, fit, ymin = fit-se, ymax = fit+se))

maps 
data <- data.frame(murder = USArrests$Murder, 
state = tolower(rownames(USArrests))) 
map <- map_data("state") 
k <- ggplot(data, aes(fill = murder))

k + geom_map(aes(map_id = state), map = map) 
+ expand_limits(x = map$long, y = map$lat), 
map_id, alpha, color, fill, linetype, size

Not  
required, 
sensible 
defaults 
supplied

Geoms Use a geom function to represent data points, use the geom’s aesthetic properties to represent variables.  
Each function returns a layer.

TWO VARIABLES 
continuous x , continuous y 
e <- ggplot(mpg, aes(cty, hwy))

 
continuous bivariate distribution 
h <- ggplot(diamonds, aes(carat, price))

RStudio® is a trademark of RStudio, Inc.  •  CC BY SA  RStudio •  info@rstudio.com  •  844-448-1212 • rstudio.com •  Learn more at  http://ggplot2.tidyverse.org •  ggplot2  3.1.0  •  Updated: 2018-12

ggplot (data =  <DATA> ) +  
  <GEOM_FUNCTION> (mapping = aes( <MAPPINGS> ),  
  stat = <STAT> , position = <POSITION> ) +      
  <COORDINATE_FUNCTION> + 
  <FACET_FUNCTION>  + 
  <SCALE_FUNCTION>  + 
  <THEME_FUNCTION>

Learn more about core 
geom_FUNCTIONS()

DataCamp course!
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Required to make PDFs

# In your “Terminal” tab
quarto install tinytex1

https://yihui.org/tinytex
Problems visit:

In your UNIX “Terminal” (not the “R Console”)

https://yihui.org/tinytex

