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Today’s Learning Goals

- Last days R visualization hands-on exercise 2C revisited...
* Understanding, using and improving someone else function

- More on data import
* File pre-check recommendations
* Using read.table() and friends for flat files

+ Writing your own functions
* What, Why, When and How

Hands-on session
* Practice, tips, techniques for troubleshooting, and best
practice guidelines for writing and debugging your functions

Recap From Last Time:

Why it is important to visualize data during exploratory data
analysis.

Discussed data visualization best practices and how good
visualizations optimize for the human visual system.

Introduced the extensive graphical capabilities of base R
with a focus on generating and customizing scatterplots,
histograms, bar graphs, boxplots, (dendrograms and
heatmaps).

Use the par() function to control fine grained details of the
afore mentioned plot types.

Stoped hands-on session at section 2C

Related Talk [MPA Link]
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Exercise 2C Revisited

» Open your previous Lecture5 RStudio project
(and your saved R script)

» Locate and open in RStudio the downloaded file
color_to_value_map.r

* This is an example of a poorly written function
typical of something you might get from a lab
mate that knows some R...

(POOR!) Color Mapping Function

map.colors <- function (value,high.low,palette) {
proportion <- ((value-high.low[1])/ (high.low[2]-high.low[1]))
index <- round ((length(palette)-1)*proportion)+1
return (palette[index])

}

1. What are the function inputs?

map.colors2 <- function(x, high.low, palette) {
proportion <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))
index <- round( (length(palette)-1) * proportion )+1

return (palette[index])

}

1. What are the function inputs?

map.colors2 <- function(x, high.low, palette) {
proportion <- ((x - high.low[l])/ (high.low[2] - high.low[1l]))
index <- round( (length(palette)-1) * proportion )+1

return (palette[index])

}

high.low




2. What is the function doing?

map.colors2 <- function(x, high.low, palette) ({

# Determine precent values of the 'high.low' range
proportion <- ((x - high.low[1])/ (high.low[2] - high.low[1]))

index <- round( (length(palette)-1) * proportion )+1

return (palette[index])

}

Let’s add a to explain the logic of the first line

2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[l])/(high.low[2] - high.low[1]))

index <- round( (length(palette)-1) * precent )+1

return (palette[index])

Let’s change the object name from proportion to soitis

more meaningful for us. Remember to change it everywhere ;-)

2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

#index <- round( (length(palette)-1) * precent )+1
index <- round( length(palette) * precent )

return (palette[index])

Perhaps we can simplify the next line, which determines the
corresponding index position in the color 'palette' vector?

2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

#index <- round( (length(palette)-1) * precent )+1
index <- round( length(palette) * precent )

return (palette[index])

Doh! What happens if our precent value is zero or very small?

value of zero, will cause a problem when
] in the last line

We will get an
accessing palette|




2. What is the function doing?

map.colors?2 <- function(x, high.low, palette) {

# Determine precent values of the 'high.low' range
precent <- ((x - high.low[1l])/ (high.low[2] - high.low[1]))

# Find corresponding index position in the color ‘palette’
# note catch for 0 precent values to 1

index <- round( (length(palette)-1) * precent )+1

return (palette[index])

Add a comment again to describe the logic of what our code is doing

3. How could we improve this function?

map.colors?2 <- function(x, high.low, palette) {

## Description: Map the values of the input vector 'x'
## to the input colors vector ‘palette’

# Determine precent values of the 'high.low' range
precent <- ((x - high.low([1])/ (high.low[2] - high.low[1]))

# Find corresponding index position in the color ‘palette'
# note catch for 0 precent values to 1

index <- round( (length(palette)-1) * precent )+1

return (palette[index])

Make more user friendly in lots of ways including adding description,
input argument defaults, error checking of inputs, tests, etc.

3. How could we improve this function?

map.colors3 <- function (x,
low.high = range(x),
palette = cm.colors(100)) {
## Description: Map the values of the input vector 'x'
## to the input colors vector ‘palette’

# Determine precent values of the 'high.low' range
precent <- ((x - low.high[2])/(low.high[l] - low.high[2]))

# Find corresponding index position in the color ‘palette'
# note catch for 0 precent values to 1

index <- round( (length(palette)-1) * precent )+1

return (palette[index])

Make more user friendly in lots of ways including adding description,

input argument defaults, error checking of inputs, tests etc.
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Pre-check recommendations

* Get organized!
» Start a new ‘project’ in a directory you know about and store
all needed project material here (input, scripts and output).
* In RStudio File > New Project > New Directory > ...

read.table() and friends for flat files

- The read.table() function is the base of all flat file import functions
* read.delim(“filename.txt”, stringsAsFactors=FALSE) TAB
read.csv(“filename.txt”, stringsAsFactors=FALSE) COMMA
read.csv2(“filename.txt”, stringsAsFactors=FALSE) SEMI-COLON
read.table(“filename.txt”, stringsAsFactors=FALSE) SPACE or ....

- What other differences are there between these functions?

* MS EXCEL file import options include:
» Export (i.e. “Save As...”) your excel data to plain text CSV format.
 Or if you must, use readxl::read_excel() to read specified parts of your sheets/
workbooks etc.

* For fast and convenient reading of very large flat files files
 Try data.table::fread() use is similar to read.table() but it automatically finds
field separators and header rows. It is also much faster!

» Saving and loading .RData files...
» Use the functions save() and load() for saving and loading multiple objects to
space efficient binary format files.

Pre-check recommendations

* Get organized!
» Start a new ‘project’ in a directory you know about and store
all needed project material there (input, scripts and output).
* In RStudio File > New Project > New Directory > ...

¢ Inspect the file
Use the UNIX commands head, less etc.
Does it have a header line or comments to be included,
ignored or removed?
Avoid file (or field names) with spaces or special characters
suchas? $,%, N, & *, }etc.
Short names are preferred over longer names.
Does the file end with a blank line or a RTN?

Your turn!

https://bioboot.github.io/bimm143_S18/class-material/testq .txt
https://bioboot.github.io/bimm143_S18/class-material/test2.txt
https://bioboot.github.io/bimm143 S18/class-material/test3.txt

Start a new RStudio Project in a clean directory

Open a new Rmarkdown document and give it a
name and descriptive text.

Download each of the above files and move them
into your Project

Experiment with read.table() to get their data
successfully input into your R session.
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What is a function

1 2
add <- (x, y=1) {
# Sum the input x and y

X +y 3

Name ( in this case “add” )

Arguments (here “x” and “y”)

Body (will return the result of the last statement)

What is a function

1 2
name.of.function <- (argl, arg2) {
statements
(something)

1 Name (can be almost anything you want )
2 Arguments (i.e. input to your function)

3 Body (where the work gets done)

Your function is treated just

like any other function...

add <- (x, y=1) {
# Sum the input x and y
X +y

}

add(x=1, y=4)
add(1l, 4)
add(1l)

add( c(1, 2, 3) )
add( c(1, 2, 3), 4 )

add(1, 2, 2)
add(x=1, y="b")




Why would you write a Why would you write a
function function

When you find yourself doing the same thing 3 or When you find yourself doing the same thing 3 or
more times it is time to write a function. more times it is time to write a function.

Why would you write a How would you write this
function function

Start with a working code snippet, simplify, reduce

Consider the advantages: calculation duplication,...

Makes the purpose of the code more clear
Reduce mistakes from copy/paste

Makes updating your code easer

Reduce duplication and facilitate re-use.




How would you write this
function

Start with a working code snippet, simplify, reduce
calculation duplication,...

How would you write this
function

Start with a working code snippet, simplify, reduce
calculation duplication,...

How would you write this
function

Start with a working code snippet, simplify, reduce
calculation duplication, ...

How would you write this
function

Start with a working code snippet, simplify, reduce
calculation duplication,...




How would you write this How would you write this
function function

Start with a working code snippet, simplify, reduce

calculation duplication, finally turn it into a function Test, Fail, Change, Test again, ...

Side-Note: Seeing and using
your function in RStudio

An easy way to visualize the code of a function is to
type its name without the parentheses ().

If you have your new function saved to a separate file
then you can load and execute it using
the source() function. E.g. source(“MyUtils.R")

The return() statement is not required in a function but
it is advisable to use it when the function performs
several computations. It has the effect of ending the
function execution and returning control to the code
which called it.




rescale <- (x, na.rm=TRUE, plot=FALSE) ({ TOday’S I_earn i n g Goal S

if(na.rm) {
rng <-range(x, na.rm=TRUE)

} else { - Last days R visualization hands-on exercise 2C revisited...
! ] SR * Understanding, using and improving someone else function
el (MR L - More on data import

* File pre-check recommendations

answer <- (x - rng[l]) / (rng[2] - rng(l]) + Using read.table() and friends for flat files

(answer)

print("is it me you are looking for?") - Writing your own functions

if(plot) { * What, Why, When and How

plot(answer, typ="b", lwd=4)

* Hands-on session
* Practice, tips, techniques for troubleshooting, and best
practice guidelines for writing and debugging your functions

}

print ("I can see it in ...")

# Can you improve this analysis code?

library(bio3d)

sl <- read.pdb("4AKE") # kinase with drug
s2 <- read.pdb("1lAKE") # kinase no drug
s3 <- read.pdb("1lE4Y") # kinase with drug

sl.chainA <- trim.pdb(sl, chain="A", elety="CA")

Your tu rn ! s2.chainA <- trim.pdb(s2, chain="A", elety="CA")

s3.chainA <- trim.pdb(sl, chain="A", elety="CA")

sl.b <- sl.chainA$Satom$b
s2.b <- s2.chainASatomS$Sb
s3.b <- s3.chainASatom$b

Concentrate on Section 1B and questions 1 to 6.

Other sections are there for your benefit. plotb3(sl.b, sse=sl.chainA, typ="1", ylab="Bfactor")
plotb3(s2.b, sse=s2.chainA, typ="1l", ylab="Bfactor")

plotb3(s3.b, sse=s3.chainA, typ="1l", ylab="Bfactor")




Homework!

New DataCamp Assignments

* |ntroduction to R Markdown
* Functions
* Loops

Muddy Point Assessment Form Link

HOW TO ENCOURAGE STUDENTS

Growth Mindset
What to say:

“When you leam
how to do a new kind of
problem, it grows your math
brain!

alch yoursell
1 not amath
person, just add the word
yet' to the end of the
senlence

“That feeling
of math being hard is
the feeling of your brair
growing”

“The point
isn't to get it all fight.
away. The point is to grow
your understanding step
by step. Whal can you try
next?”

SOURGE: Carol Dweck

Fixed Mindset
What not to say:

“Not everybody is
good at math. Just do your
best’

“That's OK, mayhe
math is not one of your
strengths.”

“Den't worry, you'll get it

il you keep uying™
udents are using the wreng
fforts might not work.
el particu arly ineptif
thelr efforts are filess.

“Great effort!
You tried your best™

*Don't accent less than optim
performance from your students.

Side-Note:

Replace “math” with “R
programing” to help reframe
your self criticism when
learning...




