1
~—

C
FE S !

G
It &
GitHu
J
.\.&
c “y

,.. B
UCarr G
s"\‘@m
an i y
€0,

htt
D //t
h
egrantl
ab.
or
9



http://thegrantlab.org




What Is Git”?

(1) An unpleasant or contemptible
person. Often incompetent,
annoying, senile, elderly or childish
N character.

(2) A modern distributed version °
control system with an emphasis 0 glt

on speed and data integrity.




What Is Git”?

(1) An unpleasant or contemptible
person. Often incompetent,
annoying, senile, elderly or childish
N character.

(2) A modern distributed version °
control system with an emphasis 0 glt

on speed and data integrity.




Version Control

Version control systems (VCS) record changes to
a file or set of files over time so that you can
recall specific versions later.

Free/opon-source

Clleni-server
Froprietary

ONUY arch (2001
Froe/open-source

Distributed

Proprietary  ThamWare (1960s°

There are many VCS available, see:
https://en.wikipedia.org/wiki/Revision_control



https://en.wikipedia.org/wiki/Revision_control

Client-Server vs Distributed VCS

Client-server approach : Distributed approach

Distributed version control systems (DCVS) allows multiple people to work on a
given project without requiring them to share a common network.




THE #1 PROGRAMMER EXCUSE
FOR LEGITIMATELY SLACKING OFF:

“The Subversion server’s down”

' ' 4 “J) ™~ s ol = 'V‘
HEY! GLT BACK

2B .72 .
: | . ..
.0_ ~ o . K‘ r

SVNsdown' Q’:
CARRY ON { IR ’i;-. %

http://tinyurl.com/distributed-advantages



http://tinyurl.com/distributed-advantages

Git 1Is now the most popular free VCS!

el Git offers:

e Speed

e Backups

e Off-line access
e Small footprint
e SIMplicity”

» Social coding

“The Subversion server’s down”

http://tinyurl.com/distributed-advantages



http://tinyurl.com/distributed-advantages

Where did Git come from?

Written initially by Linus Torvalds to
support Linux kernel and OS
development.

Meant to be distributed, fast and more
natural.

Capable of handling large projects.

Now the most popular free VCS!







Why use Git?



Q. Would you write your Lab boole in
pencil, then erase and overwrite Lk
every d&fj wikth new conbkenk?



Q. Would you write your Llab boolk in
pencil, then erase and overwrite Lk
every daj wikth new conkenk?

Version control is the lab notebook of the digital
world: it's what professionals use to keep track of
what they've done and to collaborate with others.



Why use Git”

Provides ‘snapshots’ of your project during development and
orovides a full record of project history.

Allows you to easily reproduce and rollback to past versions of
analysis and compare ditterences. (N.B. Helps fix software
regression bugs!)

Keeps track of changes to code you use from others such as
fixed bugs & new features

Provides a mechanism for sharing, updating and collaborating
(like a social network)

elps keep your work and software organized and available



Obtaining Git



: Note: You hopefully already have git installed! .
To check open the “Terminal” tab in RStudio and type

@whlch git
@ git --version

Obtaining Git




: Note: You hopefully already have git installed! .
To check open the “Terminal” tab in RStudio and type

(1)which git
@ git --version

Obtaining Git

Console Termlnal ~ R Markdown -~  Jobs -

¢+ Terminall ~ class06
zico:class@6> which git
/usr/bin/git

zico:class@b> git --version

git version 2.30.1 (Apple G1t-130)
Z1co:class06>




. Note: You might already have git installed :
To check open the “Terminal” tab in RStudio and type

(1)which git
@ git --version

Windows Only (if you have problems) . Mac Only (if you have problems) .
If the “which git” command did not work, try: | ' f the “which git” command did not work, you
where git .| may need to install select developer tools. '

. If this works see next slide. If not then you
. need to install GitBash, instructions here:

Class Computer Setup Page |  xcode-select --install

. In vour Terminal type:



https://git-scm.com/downloads
https://git-scm.com/downloads

On a Windows PC Only!

Go to: RStudio > Tools > Global Options > Terminal

Options

Gonars Shell Make sure

Code New terminals open with: Git Bash ) Git BaSh is
selected!

1 Appearance Connection

v Connect with WebSockets
Pane Layout

Miscellaneous
Packages . |

v Close terminal when shell exits
R Markdown

 Using the RStudio terminal

S .i.u' '3 :3 ‘s' E

Spelling

W Givsvn

» »~ Publishing

- Terminal



https://git-scm.com/downloads
https://bioboot.github.io/bggn213_S19/setup/

5 Note: You might already have git installed :
- To check open the “Terminal” tab in RStudio and type:

(:>wh1ch git
(:>git -—-version

Wlndows (if you have problems)
. Follow the GitBash instructions here:

Class Computer Setup Page

Mac (if you have problems)
: ' In the Terminal instal select developer tools

xcode-select --install



Configuring Git



Configuring Git
(RStudio Terminal Tab)
(...or RStudio > Tools > Shell)

# First tell Git who you are
> git config --global user.name “"Barry Grant”
> git config --global user.email “bjgrant@ucsd.edu”



Configuring RStudio



For Mac & Linux
(PC on next slide)

Go to: RStudio > Tools > Global Options > Git/SVN

1 Make sure this is ticked!
2 Make sure this i1s correct!

Console Terminal R Markdown

~ ~ Terminal ¥~ another

blitz:angher> which git
/usr/local/bin/git
blitz:another>




Appearance
Pane Layout
Packages

R Markdown

Spelling

W Git/svN

ey —
8 Publishing

. fermina

On a PC!

RStudio > Tools > Global Options > Git/SVN

v Enable version control interface for RStudio projects

Git executable:

‘/‘
SVN executable:

//Mac/Home/Document

SSH RSA Key

C./Program Files/Git/bin/git.exe

S

ol with RStudio

Browse..,

1 Make sure this is ticked!
2 Thisis the PATH for PC!




Restart RStudio!






Using Git

1. Initiate a Git repository,
2. Edit content (ie. change some files).
3.5tore a ‘shapshot’ of the current file statex



Create a new Test
RStudio project

1 New option to create
a Git repository... 2 New Git tab. ..

AW

Environment History Connections GLD
B oiff Ml Commit QU -
Staged Status Path

™ B B .gitignore

™ B B test.Rproj

Check if new Git options appear in RStudio?



Using Git in RStudio

1. Initiate a git repository for an RStudio Project
2. Do your work and edit content as normal

3. Store a ‘snapshot’ of the current file state
(a) Periodically add important files to git “Staging Area”

(b) Commit changes to your “git repository”

Rinse and repeat....






GitHub & Bitbucket

GitHub and Bitbucket are two popular hosting services for
Git repositories. These services allow you to share your
projects and collaborate with others using both ‘public’ and
private’ repositories™.

= WUBitbucket Oashbosrd «+ Toasw - Reposiorss = Seippets - Comite «

O

! puahec

YOour reposiiorias

O htts://bitbucket.or

~ https://github.com -

" " ’
lssue 2278 commanied on in Grantiabybioda

Fushed ¥ Grantab/boldg
"



https://github.com
https://bitbucket.org

a7 Qa8 QIRY sdd Q.20%

TllP WAII STRI*PT IOURN \l

5 Workers Lot New
( '@1 Toois lor Alt v

YOU ARE READING A PREVIEW OF A PAID ARTICLE, 51 1+ % W ! TOGET MORE GREAT CONTENT.

GitHub Raises $250 Million at $2 Billion
Valuation

Analytics
HOwW C0es yOour organization's




NEWS

Mose Vo W UWACews UK S A e Dovws Deemeewt A A e

Microsoft buys Github code-sharing site Top Stories
fOl‘ S?.Sbn Gangstar "Whikey’ Buiger Nbed =

VAN

Synagogue aNoXIng vitems
funecsita wian

What &0 American volers carne
sbot v




What is the big deal?

* Atthe simplest level GitHub and Bitbucket offer backup of
your projects history and a centralized mechanism for
sharing with others by putting your Git repo online.

 GitHub In particular is often referred to as the "nerds
-~aceBook and Linkedln combined”.

* At thelir core both services offer a new paradigm for open
collaborative project development, particularly for software,

* |n essence they allow anybody to contribute to any public
project and get acknowledgment.




First sign up for a GitHub account
https://github.com

Build software
better, together.

Fowerful collaboration, code review, and code management for
open source and private projects. Public projects are always free.



https://github.com

PIcK the FREE plan!

P roCamane YT T —_1

Welcome to GitHub

SbiobootStudent

Choose yOour Dersons plan
Each pran inciudes

”
- I vow wrsnliows




Your GitHub homepage

Check your email for veritication request

¥




Connecting RStudio to
GitHub

Create a Personal Access Token (PAT) on GitHub

See section 4 of lab worksheet



Skip the hello-world tutorial

https://quides.qgithub.com/activities/hello-world/

o

Learn Git and GitHub without any code!



https://guides.github.com/activities/hello-world/

Name your repo
pDIMM 143

O h Gary Pull requests issues Marketplace Explore

¥,

Create a new repository

N7 How aboul cuddily-ivention

Description (ootiona

Public

Add a
InBholize this repository with a README

README %




Copy the “Clone” HTTPS link

¥,
+

O Thas mposhory MUl reguests ssuss Marketpiace Cxplore

pimmias G Urmech =

ratlorn « New Dol reQuent Clodte new Tle Upoad TNes  Fine Ty m

Clone with HTTPS O

~ _.'- awie :- "

README . md

bimmi143




RStudio > New Project > Version Control

New Project

Create Project

New Directory

L\

Existing Directory

Version Control

. .\..:-L!::": ‘: ;!I";"“\.r ::,

Cancel




RStudio > New Project > Version Control

New Project

Back

Clone Git Repository

Repository URL: GitHub
https://github.com/bioboot/ bimm143.git Paste

T AR FSE PR RSN CUAERA I DB ST TS RSSO E RIS DBRC ST I -
Project directory name:

bimm143_github
Creaté project as subdirectory of.
~/Desktop/courses/ bimm143 Browse...

v Dpen in new session Create Project Cancel




Demo of editing, adding
committing ana pushing

Check if new Git tab
Appears in RStudio?

Environment History Connections GLD

B piff Ml Commit | L - T Now experiment editing the
Staged Status Path README.md file in RStudio
@ B @ .gitignore and adding, committing and
B B E testRproj pushing changes to GitHub

via this tab




Demo of editing, adding
committing ana pushing

Check if new Git tab
Appears in RStudio?

Environment

Staged Status
e BBE
= e

History Connections GED
B oiff Kl Commit

Path
.gitignore
test.Rproj

e & -1

Now experiment editing the

README.md file in RStudio

and adding, committing and

pushing changes to GitHub
via this tab

When you are ready copy your
different class directories/projects
to this new GitHub tracked folder



Side-note: How to edit online

Specifically lets add some Markdown content




summary

* (it is a popular ‘distributed’ version control
system that is lightweight and free

* GitHub and BitBucket are popular hosting
services for git repositories that have changed the
way people contribute to open source projects

* [ntroduced basic git and GitHub usage within
RStudio and encouraged you to adopt these ‘best
poractices’ for your future projects.



Cm 8y ™o

Introduction to Bioinformatics Class
Bioinformatics

Index of Material

&

Here I: (1) forked Serina’s Repo, (2) Chose the “minimal” theme, (3) Edited _config.yml (adding logo and title)



|_earning git can be painful!

However In practice it Is not nearly as crazy-making as

the alterna

e Docum

e Halr-ral

Ves:
ents as email attachments

sing ZIP archives containing file salao

« Am | working with the most recent data”

e Archae

logical "digs” on old emall threads and

uncertainty about how/if certain changes have been
made or issues solved



Finally Please remember that GitHub

and BitBucket are PUBLIC and that

you should cultivate your professional
and scholarly profile with intention!




http://thegrantlab.org
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Reference Slides

Command Line GIT



Using Command Line Git

1. Initiate a Git repository
2. EAit content (i.e. change some files).
3. Store a ‘sma[pskoé’ of the current file stabe.x



Initiate a Git repository



Initiate a Git repository

> cd ~/Desktop

> mkdir git_class # Make a new directory

> cd git_class # Change to this directory
> git init # Our first Git command!
> |8 -a # what happened?



Side-Note: The .git/ directory

Git created a ‘hidden’ .git/ directory inside your
current working directory.

You can use the ‘Is =a’ command to list (1.e. see)
this directory and its contents.

This is where Git stores all its goodies - this Is
Git!

You should not need to edit the contents of the .git
directory tor now but do feel free to poke around.



Important Git COmmands

, ~ # report on content changes

AR A A R RO A S S S e Rl - R R e e T e R R S R T e R e R e e o e R T R R s S R e D T T R R R e AR e R Tl B At S s STwes BN R S NS SR S S e S S e PN S S R AR ¥

g S glt ‘add <f|\ename> #sz‘age/tracka file
> git commit -m message  # snapshot J

E‘ AR S A T N s A AP N s O S AN DO N NP S o SO S 0 St A A e s e e S S : RS R e I TR R SN S ;

. S ——




Important Git COmmands

# re,oorz‘ on com‘ent changes

X — - . _

BN AR AP AN ST IR EPEAPIS:

> git add <fi\ename> P sz‘age/track afile
> glt commlt -M message #snapshot

S S e S s e

You Wl// use z‘hese z‘hree commands again and again in your G/z‘ Workf/owl




Git TRACKS your directory content

Mmoo e e e e e . SRS A SRt e

i . To get a report of changes (smce \ast Commlt) Lse:
| > git status

A DO

e

'+ You tell Git which files to track with: e
> git add <filename> |
‘ This adds files to a so called STAGING AREA ,

(akin to a “shopping cart” before purchasing). *

!

| * You tell Git when to take an historical SNAPSHOT of
- your staged ftiles (/.e. record their current state) with:

> git commit -m ‘Your message about changes

bﬂl =R OB e A e e s A SRR EoR RIS T SRR = SV SeSi ev s e e STkl SR AT MJ

S PR

TN i




Example Git workflow

Eva creates a README text file
(this starts as untracked)

Commit changes”
(records snapshot of staged files!)

Adds file to STAGING AREA*®
(tracked and ready to take a snapshot)




Example Git workflow

“va creates a README text file

Adds file to STAGING AREA*

Commit changes®

—va modifies README and adds a ToDo text file _’

Adds both to STAGING AREA*




1. Eva creates a README file

> # cd ~/Desktop/git_class

> # git init

> echo "This is a first line of text." > README
> git status # Report on changes

# On branch master |

# Initlal commit

... to include in what will be committed)

# README

#
# nothing added to commit but untracked files present (use "git add" to track)



2. Adds to ‘staging area

> git add README  # Add README file to staging area
> git status # Report on changes

# On branch master

#

# Initial commit

#|Changes to be committed: |

# —(usegitrr=—cached =<fite>..." to unstage)

new file: README

H H H*



3. Commit changes

> git commit -m “Create a README file” # Take snapshot
# [master (root-commit) 8676840] Create a README file

# 1 file changed, 1 insertion(+)
# create mode 100644 README

> git status # Report on changes

# On branch master
# nothing to commit, working directory clean



4. Eva modifies README file
and adds a ToDo file

> echo "This is a 2nd line of text." >> README
> echo "Learn git basics" >> ToDo

> git status # Report on changes

# On branch master
#
# Changes not staged for commit:
# (use "git add <file>..." to update what will be committed)
(use "git checkout -- <file>..." to discard changes in working directory)

modified:

#

#

#

#

# Untracked files:
# (use "git add <tile>..." to include in what will be committed)
#

#

#

#

no changes added to commit (use "git add" and/or "git commit -a")



5. Adds both files to ‘'staging area’

> git add README ToDo # Add both files to ‘staging area’
> git status # Report on changes

# On branch master
# Changes to be committed:
# (use "git reset HEAD <file>..." to unstage)

modified: README
new file: ToDo

H H H HF



6. Commits changes

> git commit -m "Add ToDo and modify README"

# [master 7b679fa] Add ToDo and modify README
# 2 files changed, 2 insertions(+)
# create mode 100644 ToDo

> git status

# On branch master
# nothing to commit, working directory clean



Example Git workflow

1. “va creates a README text file
2. Adds file to STAGING AREA~
3. Commit changes*

N\

—va modifies README and adds a ToDo text file

Adds both to STAGING AREA*

Commit changes™

4.
0.
0.

...But, how do we see the history of our project changes?



git log: Timeline history of
snapshots (1.e. commits)

> git log

# commit 7be79fa’747e8640918fcaad/7e4c3t9¢c70c87b170
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:43:40 2015 -0400

#

# Add ToDo and finished README

#

# commit 867684016107 70ae32e2td4taee0/7d1d5¢c68619¢
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:26:40 2015 -0400

#

# Create a README file

#



git log: Timeline history of
snapshots (1.e. commits)

> git log

# commit 7be79fa’747e8640918fcaad/7e4c3t9¢c70c87b170
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:43:40 2015 -0400

#

# Add ToDo and finished README

#

# commit 867684016107 70ae32e2td4taee0/7d1d5¢c68619¢
# Author: Barry Grant <bjgrant@umich.edu>

# Date: Thu Jul 30 11:26:40 2015 -0400

#

# Create a README file

f Past




Side-Note: Git history Is akin
to a grapnh

Nodes are commits labeled by their
| unique ‘commit ID’.

3 (This is a CHECKSUM of the commits |
~author, time, commit msg, commit content |
[ and previous commit ID). |

AR Srsiet A e e e e T e R e

| currently checked out commit (typically the
most recent commit).

Bt R AP IS Al AP CBII e A SO TN

Time



Projects can have complicateo
grapns due to branching

Master Feature

7‘7. : SIX2 @

| 0.

| Branches allow you to work independently

199K...

of other lines of development we will talk
more about these later!



Key Points:

You explicitly and iteratively tell git what files to
track (“git add”) and snapshot (“git commit”).

Git keeps an historical log “(git log”) of the
content changes (and your comments on these
changes) at each past commit.

't IS good practice to regularly check the status
of your working directory, staging arena repo
(“git status”)



Break



Summary of key Git commands:

; > git status # Get a status report ot Changes since Iast Commlt

AR TR fad o e BN ASAPII A INAE S e

; > git IOg # Rewew your commit hlstory

: RN .

EINT AL B o e e Fan e S I B R AN : = BGOSR RPN RIS T GRS ARSI (R e SNSRIt [ J,ﬁ

—
t > glt dlff <comm|t |D> <comm|t |D> # Inspect content differences |

| > glt checkout <commit.ID> # Nawgate through the commit history E

ik —— e s S A S A IR M SIS Aol

S e e ;




Your 'Staging
Directory  Area’

status

ff <

Local
Repository

log



git diff: Show changes
petween commits

> git diff 8676 7b67

# diff --git a/README b/README

# index 73bc85a..67bd82¢c 100644
# --- a/README

# +++ b/README

#@@-1+1,2 @@

# Thisis a first line of text.

# +This is a 2nd line of text.

# diff --git a/ToDo b/ToDo
# new file mode 100644

# index 0000000..14fbd56
# --- /dev/null

# +++ b/ToDo

# @@ -0,0 +1 @@

# +Learn git basics




git diff: Show changes
petween commits

~ git diff 7b67 8676

# diff --git a/README b/README

# Index 6/bd82c..73bc85a 100644
# --- a/README

# +++ b/README

#@@-1,2 +1 @@

# This is afirst line of text.

#

# diff --git a/ToDo b/ToDo

# deleted file mode 100644
# index 14tbd56..0000000
# --- a/loDo

# +++ /dev/null

#@@ 1+0,0 @@

#




git diff: Show changes

between commits
# Index 73bc85a..07bd82¢c 100644
¥ Q@ -1 +1.2 Q@ 7‘7
# +++ b/ToDo

> git diff 8676 ## Difference to current HEAD position!
# diff --git a/README b/README

# --- a/README ?

# +++ b/README

# This Is a first line of text.

# +This is a 2nd line of text.

# diff --git a/ToDo b/ToDo

# new file mode 100644

# Index 0000000..14tbdb56

# --- /dev/null

¥ @@ -00 +1 @@

# +Learn git basics



HEAD aadvances automatically with
each new commit

?
HEAD gi{ _

/ To move HEAD (back or forward)

on the Git graph (and retrieve the
associated snapshot content) we
can use the command;

I > git checkout <commit.ID>




git checkout: Moves HEAD

> more README
This is a first line of text.
This is a 2nd line of text.

> git log --oneline m 7‘
# 7bo679fa Add ToDo and finished README

# 8676840 Create a README file |

2




git checkout: Moves HEAD
(e.g. back in time)

> more README
This is a first line of text.
This is a 2nd line of text.

> git log --oneline
# 7bo679fa Add ToDo and finished README
# 86/6840 Create a README file

RS O RGP e o e o e

= git checkout 86768
| # You are in 'detached HEAD' state...<cut>...
f # HEAD is now at 8676840... Create a README file

Mok i L

"~ more README
This Is a first line of text.

> git log --oneline
# 86/6840 Create a README file



git checkout: Moves HEAD
(e.g. back to the future!)

> git checkout master
# Previous HEAD position was 8676840... Create a README file

# Switched to branch 'master’

> git log --oneline m 7‘
# 7bo679fa Add ToDo and finished README

# 8676840 Create a README file |

2

> more README
This Is a first line of text.
This Iis a 2nd line of text.




Side-Note: There are two* main ways to
use git checkout

* Checking out a commit makes the entire working
directory match that commit. This can be used to
view an old state of your project.

> git checkout <commit.ID>

* Checking out a specific file lets you see an old
version of that particular file, leaving the rest of
your working directory untouched.

> git checkout <commit.ID> <filename>



You can discard revisions
with git revert

* [he git revert command undoes a committed
snapshot.

* But, instead of removing the commit from the
oroject history, it figures out how to undo the
changes introduced by the commit and appends

a hew commit with the resulting content.

> git revert <commit.|D>

* This prevents Git from losing history!



Removing untracked files

with git clean

* The git clean command removes untracked files from
your working directory.

e Like an ordinary rm command, git clean is not
undoable, so make sure you really want to delete the
untracked files before you run it.

> git clean -n

> git clean -f

dry run display of files to be ‘cleaned’

remove untracked files



GUIs

Tower (Mac only)
GitHub_Desktop (Mac, Windows)
SourceTree (Mac, Windows)
SmartGit (Linux)
RStudio

https://git-scm.com/downloads/quis



https://git-scm.com/downloads/guis

